1

I recently noticed that some sites/blogs I visit using either Safari or Firefox are showing fonts incorrectly. My site is included which is why I realised this was a problem. Instead of the correct styles the main font of the page is displaying bold and italic. Is this a problem on my system? How can I fix it?

Here is a picture of problem — fonts are showing in bold and italic when they should be unstyled.

1

When I view this page in Firefox (12.5 beta) I am seeing this text as you probably intended it - no bold and/or italic. Since you reported that the problem is occurring in both Safari and Firefox, it likely is not user preferences in both browsers, which can be set to use user-defined fonts instead of those dictated by CSS or HTML instructions. Nevertheless, I'd check each browser's display preferences first to see if this isn't the case.

Otherwise, this may be a problem with your fonts cache, so clearing it may solve your problem. You can easily do this by opening up Terminal.app and entering the following command (this clears the font cache for the current user account; if you have other accounts, they won't be affected):

atsutil databases -removeUser

  • thanks. i checked the font preferences and that wasn't it. I put that command into terminal and doesn't seem to have any effect. now i'm not sure that terminal is targeting the right thing. (how can i ensure it's using the account i want?) – sarahlikesgreen Apr 18 '12 at 18:07
0

I was suffering from this horrible issue for a while and couldn't find fixes anywhere. This worked for me and hope it helps anyone finding it. Upvote this if it helps so that others can find this easier.

Font Book (Cmd + space -> type 'Font Book')

Option A: Disabling / enabling fonts

  1. Disable all fonts, if that resolves the issue, then
  2. Enable fonts one by one until you figure out the problem font
  3. Delete the problem font

Option B: (Option A did not work for me)

  1. At Font Book, select "File" -> "Restore Standard Fonts"
  2. Voila, it worked for me straight away.

So it seems the issue was that one or more of my standard font was corrupted or overriden and needed to be restored.

-2

Some times it is the problem with registry.You could take backup of registries so that if you face something like this then you can revert the changes by applying the old settings. Or secondly make system restore points time to time, and when you feel problem restore it to earlier time.

  • I thought only Windows systems had registry's? – bassplayer7 Dec 1 '12 at 13:46
  • Could you expand on this - as it is written it looks like an answer for Windows OS as opposed to Mac. – bmike Dec 1 '12 at 19:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .