I noticed recently that new programs (newly installed or downloaded) are not opening on first try on my MacBook Pro, or on my wife's MacBook. Both are running 10.7.3.

On first launch, new programs take a very long time to start. When they do show up in the Dock, they either bounce for a long, long time and then immediately exit, or finally stop bouncing and show up as if closed (I still have the little highlight turned on so I can see what is open or closed). When clicked, the icon disappears from the Dock. When I re-launch the app, it opens instantly with no issues - it is just the initial launch that seems screwy.

Have not been able to figure out what is happening with this, as my searches elsewhere haven't turned anything up. Any ideas? Related to some kind of sandboxing? It's not a huge issue but it is kind of annoying.

  • Is this for any Application you down load or just specific Apps? – MrDaniel Apr 16 '12 at 19:41
  • Can you provide an example of a program that was slow to start for the first time? – MrDaniel Apr 16 '12 at 19:41
  • Seems to be mostly apps that don't have an installer - open source apps is where I noticed it first (Burn, Platypus, The Unarchiver). Platypus is doing it right now - I downloaded a new version of the program, launched it, and it has been bouncing in the Dock for a few minutes. Now it stopped; I click the icon, it disappears from the Dock, I relaunch it, it opens immediately. Weird. – dr.nixon Apr 18 '12 at 21:07
  • Out of curiosity are you jumping off and doing other things while you are waiting for the never ending Apps in question to start up? – MrDaniel Apr 18 '12 at 21:20
  • Not intentionally, but I am often multitasking (firing up program A, then opening program B because I need to work in that one too...) – dr.nixon Apr 20 '12 at 3:10

This may be another case of Lion being a quiter. And utilizing OS X Lion's Auto Termination and additionally OS X Lions Sudden Termination feature.

Lion will quit your running applications behind your back if it decides it needs the resources, and if you don’t appear to be using them. The heuristic for determining whether an application is “in use” is very conservative: it must not be the active application, it must have no visible, non-minimized windows — and, of course, it must explicitly support Automatic Termination.

A program that is "taking to long to start" seems like a perfect candidate for the OS to kill.

Also it makes perfect sense for when you come back the second time and they start up, since Lion would have saved state on the program.

  • That could be it - makes sense anyway. – dr.nixon Apr 20 '12 at 3:11

If they're downloaded, you need to confirm that you want to run them before they'll start. (This is the "This program was downloaded from [website] on [date]. Do you want to run it?" dialog.)

Are they timing out at that dialog (while they wait for you to confirm it)?

  • If these applications are using Java, you may be falling "victim" to Apple's new security policy regarding Java and the Flashback malware. – user479 Apr 17 '12 at 23:32
  • 1
    Programs are not timing out. I get the confirmation prompt first, after selecting "Yes" to launch the program I see the behavior described in the question. I don't think the programs use Java; I was seeing the issue prior to the two most recent Java security updates. – dr.nixon Apr 18 '12 at 21:09

Dr.nixon, you mentioned the application causing the problem in your reply to MrDaniel. The application causing you problems is The Unarchiver. I tried running programs in a new user account and them worked there. I noticed this was because I was opening zip files with the built in mac "archive utility".

I installed the program Archiver instead and opened rar files and zip files and ran then opened the applications that I'd just unarchived. I no longer experienced the applications bouncing in dock then disappearing after I closed the "This program was downloaded from.." dialog.

So find a new utility to unarchive and it should fix your problems...which sucks because I The Unarchiver is definitely my favorite utility of it's kind, it both functions and looks like an utility made by apple (plus it's free). I think I'll send an bug report to the folks who make The Unarchiver.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .