758

It seems that ssh-add -K ~/.ssh/id_rsa will load your key but will ask for the password each time you reboot.

I am looking for a solution that would not require me to re-enter the key password between logins.

9
  • 1
    Can you say a little more about when the password prompt comes up for you? I ask because I have an ssh-key for a remote server, which I assure you is not the same as my Mac login password or anything, and I haven't had to enter the password for the ssh-key for years. I can just open up a terminal, type "ssh <server>", and I'm there. I think I first set this key up under OSX 10.5. id_dsa, but I don't think that should matter.
    – Michael H.
    Apr 13, 2012 at 16:39
  • My id_rsa key has a password on it.
    – sorin
    Apr 13, 2012 at 16:46
  • I also have the problem that I solved this so long ago that I can't remember exactly what I did. But I think the idea is to not run ssh-add, but just run ssh directly. You should get a window popping up that will as the pass phrase for the key, and with a checkbox to let you store it in your keychain. Apr 13, 2012 at 18:19
  • 1
    @Sorin - so does mine! I had to enter it once, long ago, and the Mac has saved it for me ever since. Hopefully Harald's advice will help.
    – Michael H.
    Apr 13, 2012 at 18:35
  • Do you mean the Keychain password (i.e. your login password) or the key's passphrase? If it's the latter, re your passphrases definitely stored in Keychain? You can check this by opening Keychain Access and looking for it in the login keychain. Apr 20, 2012 at 11:41

6 Answers 6

1127

It is not possible to add private key to Keychain, but you can store passphrase for private key in Keychain. On OSX, the native ssh-add command has a special argument to save the private key's passphrase in the OSX Keychain, which means that your normal login will unlock it for use with ssh. On OSX Sierra and later, you also need to configure SSH to always use the Keychain (see Step 2 below).

Alternatively you can use a key without a passphrase, but if you prefer the security that's certainly acceptable with this workflow.

Step 1 - Store passphrase in the Keychain

In the latest version of MacOS (12.0 Monterey), just do this once:

ssh-add --apple-use-keychain ~/.ssh/[your-private-key]

Or in versions of MacOS older than 12.0 Monterey, use:

ssh-add -K ~/.ssh/[your-private-key]

Enter your key passphrase, and you won't be asked for it again.

(If this fails, make sure you are using Apple's version of /usr/bin/ssh-add and not something installed with brew etc.; check with which ssh-add)

Step 2 - Configure SSH-agent to always use the Keychain

(Note: In versions of OSX prior to Sierra, this is not necessary)

It seems that OSX Sierra removed the convenient behavior of persisting your keys between logins, and the update to ssh no longer uses the keychain by default. Because of this, you need to change one more thing for secure persistent key storage.

The solution is outlined in this github thread comment. Here's what you do:

  1. Ensure you've completed Step 1 above to store the passphrase in the keychain.

  2. If you haven't already, create an ~/.ssh/config file. In other words, in the .ssh directory in your home dir, make a file called config.

  3. In that .ssh/config file, add the following lines:

     Host *
       UseKeychain yes
       AddKeysToAgent yes
       IdentityFile ~/.ssh/id_rsa
    

    Change ~/.ssh/id_rsa to the actual filename of your private key. If you have other private keys in your ~/.ssh directory, also add an IdentityFile line for each of them. For example, I have one additional line that reads IdentityFile ~/.ssh/id_ed25519 for a 2nd private key.

    The UseKeychain yes is the key part, which tells SSH to look in your OSX keychain for the key passphrase.

  4. That's it! Next time you load any ssh connection, it will try the private keys you've specified, and it will look for their passphrase in the OSX keychain. No passphrase typing required.

28
  • 8
    @Poulsbo & @Abram -- see my update, Sierra changed the automatic behavior and now you have to run ssh-add -A manually to load your saved keychain. Some possible solutions referenced above.
    – trisweb
    Jan 3, 2017 at 22:20
  • 3
    @trisweb Thanks for the tip. joshbuchea's solution of modifying the .ssh/config file looks promising! See github.com/lionheart/openradar-mirror/issues/…
    – Poulsbo
    Jan 6, 2017 at 21:19
  • 19
    Works great! In my case I needed to use the A flag in addition to the K one to add my keys to the keychain and register the passphrase into it (ssh-add -AK ~/.ssh/[your-private-key]). Thanks!
    – youssman
    Mar 7, 2017 at 22:28
  • 5
    Even with the usekeychain option, I still find that my keychain will drop the .ssh/id_rsa key on reboot.
    – Chogg
    May 2, 2018 at 18:39
  • 5
    I did exactly the same and my Mac still drops the key on reboot. Nov 22, 2018 at 8:57
44

I had a similar problem, in that I was being asked every time for my pub-key passphrase. Per suggestion of user "trisweb" above, I turned on these options to ~/.ssh/config:

Host *
  UseKeychain yes
  AddKeysToAgent yes
  IdentityFile ~/.ssh/id_rsa

But it still prompted every time I wanted to use ssh. Eventually I turned on ssh -v and found this debug line:

debug1: key_load_private: incorrect passphrase supplied to decrypt private key

I then opened my keychain in "Keychain Access.app", found the key named "SSH: /Users/username/.ssh/id_rsa" and opened it up. I clicked "Show password" to disclose the password and indeed found that the passphrase in the keyring was an old passphrase. I updated the passphrase in Keychain Access, and now password-free works.

I could have also updated the passphrase with this phrase:

ssh-keygen -p -f ~/.ssh/id_rsa
1
  • In my Mac the password is saved in “password” category of “iCloud” chain. I thought it was in “log in” chain. Mar 31, 2020 at 4:53
31

To all where the above did not work, my issue appears to have been because I was duplicating the UseKeychain yes & AddKeysToAgent yes in all ssh key profiles / shortcuts. I updated my ~/.ssh/config file to declare these only once and they now all load on login without prompting for passwords on startup, e.g:

Host foo
  HostName foo.com
  User fooUser
  IdentityFile ~/.ssh/foo

Host bar
  HostName bar.com
  User barUser
  IdentityFile ~/.ssh/bar

########################
# Keep the default configuration 
#  as the last item in this file
Host *
  UseKeychain yes
  AddKeysToAgent yes
  IdentityFile ~/.ssh/foo
  IdentityFile ~/.ssh/bar
3
  • 3
    I would recommend Host * be after specific host rules. See man ssh_config for details. Mar 31, 2020 at 4:31
  • 1
    Thank you so much for this. Where are the docs for this i.e. how did you work this out? Jun 15, 2021 at 16:06
  • 1
    ...actually, this did not work for me: I have a setup where Host bar has HostName foo.com too (i.e. two different configs for the same site). IdentityFile ~/.ssh/foo was always used. To fix, I had to move the Host * section to the bottom, as @FranklinYu suggests. I think this is because > For each parameter, the first obtained value will be used. linux.die.net/man/5/ssh_config Jun 18, 2021 at 3:34
19

Also, in macOS Sierra and High Sierra (don't know about previous versions), running ssh-add -A will get the agent to load all keys whose passphrases are stored on Keychain... So very handy

Note that these option flags have been renamed and the old ones deprecated in later versions of macOS. From the ssh man page:

APPLE_SSH_ADD_BEHAVIOR
Enables or disables the older processing of the -A and -K options used in earlier macOS releases. These options have been renamed --apple-load-keychain and --apple-use-keychain respectively.
However, -A and -K still behave as in earlier releases except in the following circumstances:

  • If a security provider was specified with -S or SSH_SK_PROVIDER, or if APPLE_SSH_ADD_BEHAVIOR is set to the value “openssh”, then ssh-add uses standard OpenSSH behavior: the -A flag is not recognized and the -K flag behaves as documented in the DESCRIPTION section above.
  • Otherwise, ssh-add -A and -K will behave as in earlier macOS releases. A warning will be output to standard error unless APPLE_SSH_ADD_BEHAVIOR is set to the value “macos”. Note: Future releases of macOS will not support neither -A nor -K without setting this environment variable.
1
  • This is not needed if one just configures ssh correctly, as per the accepted answer.
    – oligofren
    Feb 4 at 5:42
8

Answer on OSX 12.0 Monterey

You can now use the flag --apple-use-keychain to accomplish exactly this.

ssh-add --apple-use-keychain ~/.ssh/id_rsa 

Add this to your .zshrc or .bashrc file to have it load from your keychain on new logins / terminal instances.

This replaces the -K and -A flags:

WARNING: The -K and -A flags are deprecated and have been replaced
         by the --apple-use-keychain and --apple-load-keychain
         flags, respectively.  To suppress this warning, set the
         environment variable APPLE_SSH_ADD_BEHAVIOR as described in
         the ssh-add(1) manual page.
3
  • This is redundant if just configuring ssh correctly once, as per the accepted answer.
    – oligofren
    Feb 4 at 5:46
  • this option no longer exists...
    – airtonix
    Feb 10 at 22:32
  • @airtonix what os version are you on? Works fine for me on 12.1. Feb 11 at 1:25
-3

Add the public key in:

.ssh/known_hosts

Public key usually are on:

/home/user/.ssh/id_rsa.pub

Hope that helps

2
  • 9
    I think mean the authorized_keys May 23, 2012 at 18:47
  • Anyway, this doesn't work if you have more than one key!
    – sorin
    May 24, 2012 at 10:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .