9

I happen to have a TP-LINK TL-WN821N (it's a WiFi USB stick) around. Is there any chance to get that working on a Mac mini running OS X Lion?

There are no official drivers but it seems there are some kind of drivers for the ATHEROS AR9170+AR9102 chipset from other vendors like Ralink.

7
+50

Update: The below hack worked when using D-Link's DWA-130 Rev. D drivers instead of the DWA-160 ones. Compatible drivers using the same chipset were identified with the help of the WikiDevi database.


A quick Google search shows that someone has had success in using D-Links DWA-160 driver (which uses the same chipset), although not without some minor hacking to make the driver recognize the different hardware IDs:

  • Install driver package
  • Extract kernel extension from installer:
    • Show Package Contents of the installer
    • unarchive Archive.pax.gz
    • grab AtherosOtusMac.kext
  • Edit plist and change or add your device id and product id converted to decimal (illustrated below):
    • Show Package Contents of AtherosOtusMac.kext
    • Open Info.plist within (using either Xcode or a text or XML editor)
    • Open System Information, find your TP-Link under USB and note down Product ID and Vendor ID
    • Convert both numbers from hexadecimal to decimal (you can use Calculator.app)
    • Replace idProduct and idVendor on the first model with your numbers
  • Use kext helper to install your modified AtherosOtusMac.kext
  • use DWA-160.app (in /Applications/Utilies) to connect

Although considering the price of a new Wifi USB stick with OS X drivers, this may not be worth the effort, unless you're doing this sort of thing for fun :-)

Illustration of the plist step (with my USB mouse as example, because I don't have a TL-WN821N laying around): Plist step illustrated

  • This looks like an excellent answer! Unfortunately I can't seem to get past the first step. The installation of the driver for D-Links DWA-160 driver fails on my OS X Lion. At the download page D-Link states "Supports Mac OS 10.4 and 10.5." so I might be out of luck. – Jonas Elfström Apr 19 '12 at 20:15
  • Recommendations for 802.11n compatible WiFi USB sticks with OS X drivers would be appreciated. My old Mac mini only supports 802.11g. – Jonas Elfström Apr 19 '12 at 20:38
  • 1
    I tried another, older, TP-LINK WN821N stick (productid 4098 instead of 28693 as the newer one has, same vendorid 3315). And with that it actually connects but only for a couple of seconds. After a few connect/disconnect loops it crashes. – Jonas Elfström Apr 22 '12 at 8:14
  • 1
    Woohaa! I removed everything Atheros-related from /System/Library/Extensions and then I downloaded the Netgear DWA-130 D drivers for Mac OS X (it seems to be the same as for DWA-160). I patched the Info.plist and followed your instructions above. This time it worked! Thanks a lot for all of your excellent help @IngmarHupp – Jonas Elfström Apr 22 '12 at 21:13
  • 1
    It's not Netgear but D-Link DWA-130 REVD sorry for the typo. dlink.com/products/?pid=566 – Jonas Elfström May 11 '12 at 6:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .