Every time I download an image from a site, using Safari, as soon as the images finish download, it opens Preview to show me the image. Other browsers don't do that.

Try this link.

How do I prevent Safari from launching Preview?


In the general pane of the preferences, uncheck the 'Open "safe" files after downloading'. I have mine unchecked and Safari doesn't open the file downloaded in your example link.

| improve this answer | |
  • I missed that! That solves the problem! Thanks!!!!!!!!!! – DuckDucking Apr 12 '12 at 12:13
  • How do you make Safari behave like other browsers and open the image in a browser window or tab, instead of using Preview? – Peter Flynn Apr 30 '19 at 21:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .