4

I just installed TextWrangler 4, and now when I try to use BBAutoComplete version 1.5.3, I get the error message seen below.

enter image description here

Is there a workaround to make BBAutoComplete work with TextWrangler 4?

5

Yes, it breaks version 1.5.3, and yes, there's a workaround. But now it's unnecessary, because version 1.5.4 has been released and it solves the problem.

If for some reason you want to still use 1.5.3, you can do the following:

In the script ~/Library/Application Support/TextWrangler/Scripts/BBAutoComplete, there is a function canCompleteInWindow(w). This function needs to be modified to work with TextWrangler 4.

Open the script in AppleScript Editor.

As it ships, there is a function in the script that reads

on canCompleteInWindow(w)
    tell application "TextWrangler"
        return class of w is in {text window, disk browser window}
    end tell
end canCompleteInWindow

Change it so it reads

on canCompleteInWindow(w)
    tell application "TextWrangler"
        return class of w is in {text window, disk browser window, project window}
    end tell
end canCompleteInWindow

Save the script. BBAutoComplete should now work with TextWrangler 4.

2

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .