I've been using an IBM SpaceSaver II very successfully with my Mac Pro through one of those cheap PS2 > USB converters for about the last six or seven years. Recently, possibly after upgrading to Snow Leopard, a wizard popped up telling me the keyboard type was not detectable and asking me to type the key to the right of the left Shift key (KTTROTSK).

Unfortunately this wizard just hangs and doesn't seem to register the keypress and indeed once I've cancelled this and carried on with OS X the KTTROTSK does not do anything at all. In addition, the Cmd and Option keys are reversed and swapping them around in the Keyboard pref pane has no effect. Can anyone help please?

  • Any more information on the PS2 to USB adapter? Maybe for some odd reason its is no longer compatible with 10.7 just like how Apple Pulled the Apple USB modem driver support in 10.7. Seems highly unlikely, but would be good to know as much about the adapter as possible. – MrDaniel Apr 10 '12 at 14:16
  • Also what kind of Mac are you connecting it to? – MrDaniel Apr 10 '12 at 14:17
  • @MrDaniel - its a 2010 MacPro (2 x Quad core). The PS2-USB adapter is just an el cheapo from ebay (ebay.co.uk/itm/…). I have a few of them and one MacPro at work (runs SL) and one at home (2nd gen machine but runs Lion and has no issues) and yes, I have switched the adapters and keyboards around in an effort to replicate the issue ;-) – 5arx Apr 10 '12 at 14:26
  • Does the KeyboardSetupAssistant always crash when opened. Try opening it at /System/Library/CoreServices/KeyboardSetupAssistant.app Try it with other USB keyboards that do not need a PS2 adapter too. – MrDaniel Apr 10 '12 at 16:06

Odd. I use an old-school keyboard as well, and have not experienced the same problem. I can offer no suggestion on the software side, but you may find it useful to know that you can get a modern USB keyboard with IBM buckling spring keys at http://pckeyboard.com/page/category/UKBD

  • Thanks! If all else fails I'll be investing in one of those puppies! ;-) – 5arx Apr 10 '12 at 14:24

First Try to fix the issue with the KeyboardSetupAssistant application opening and hanging. This may be due to the fact that the Keyboard Type property list file may have became corrupted.

Try removeing the the com.apple.keyboardtype.plist file.


And then re-runing the KeyboardSetupAssistant application.

  1. Open the Keyboard System Preferences Pane and reset the "Modifier Keys" selecting Restore to Defaults

  2. Quit System Preferences

  3. Reopen System Preferences for the Keyboard and then re-configure the Modifier Keys to the way you want them. Also Verify what is being listed in the Select Keyboard drop down, make sure there is only one keyboard in the drop down.

  4. Click OK and then quit System Preferences

  • Thanks for the detailed instructions. the KeyboardSetupAssistant still hangs however I did notice that there are two entries in the Select Keyboard dropdown - one is for the TrackPoint in the middle of the keyboard. Could this be causing an issue? I've never noticed more than one entry here before ... – 5arx Apr 11 '12 at 8:52
  • That could be an issue, especially if there is really only one keyboard attached, do multiple items appear on the Macs where everything is working as expected? – MrDaniel Apr 11 '12 at 13:26
  • Have you tried changing the modifier keys for both "things" listed? – MrDaniel Apr 11 '12 at 13:29
  • Yes just tried it - no change :-( – 5arx Apr 11 '12 at 15:26
  • Does the KeyboardSetupAssistant always crash, even with straight USB keyboards? – MrDaniel Apr 11 '12 at 16:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .