I'm experiencing a problem with TrueCrypt. The problem is described elsewhere but not resolved for me.

When attempting to mount encrypted containers, the following error is generated:

hdiutil: attach failed - no mountable file systems

Other resources indicate that the problem is related to the version of MacFUSE. I have tried a few versions but have been unable to find a pair that work for my system.

It would be great to:

  • get any fix suggestions
  • learn which version of MacFUSE is used successfully by someone in my situation.

My System:

  • Mac OS X 10.6.8 (Snow Leopard)
  • Mac Mini 1.66Ghz Core Duo
  • 2 GB RAM
  • TrueCrypt 7.1A

Update 1

After switching from MacFUSE to FUSE for OS X (OSXFUSE), as suggested in answers:

  • TrueCrypt volumes could be mounted read only.

Attempts to mount with write access continued to fail with the above error. I can't be sure whether this is new since I changed over.

Update 2

Read/write succeeds for a TrueCrypt container formatted as Mac OS Extended.

The container I wish to open was originally created on a Windows system. diskutil info describes it as FAT16. The size of the container is 10.5 MB on disk when not mounted. When mounted as read only:

enter image description here

(Dates are a bit quirky?)

  • Related to apple.stackexchange.com/questions/20037/… but I think focussing on a different element
    – Rory
    Apr 10, 2012 at 12:45
  • Are you using an encrypted partition or a file-hosted volume? If the latter, what is the filesystem of the partition the file is hosted one?
    – Old Pro
    Apr 21, 2012 at 21:34
  • Errm well it's a normal truecrypt container file, created on windows TC being opened from my mac hard drive so File System: Journaled HFS+ Type: hfs Name: Mac OS Extended (Journaled)
    – Rory
    Apr 21, 2012 at 21:37
  • Do you have full ownership and read/write permissions to the TC container file on your Mac drive, including rw permission to the folder it is in?
    – Old Pro
    Apr 21, 2012 at 21:44
  • @OldPro did CHMOD 777 on file and directory to be sure - no change :(
    – Rory
    Apr 28, 2012 at 11:09

3 Answers 3


I have used TrueCrypt 7.1a on Mas OS X 10.6.8 with OSXFUSE 2.3.8 with no problems. MacFuse is dead. TrueCrypt's official Mac installer 7.1a installs OSXFUSE as did 7.1. Not sure how you installed TrueCrypt but if not with the Mac installer, then uninstall what you have (including MacFuse) and install using the installer.

Also make sure you have read/write/ownership of the TC container file on the disk.

  • Truecrypt's 7.1a installer actually still installs MacFuse - see screenshot
    – Rory
    Apr 21, 2012 at 11:14
  • @Rory, I suppose it depends on what OS you are installing onto - see screenshot - or where you got the installer from.
    – Old Pro
    Apr 21, 2012 at 16:16
  • @Rory - Even TrueCrypt 7 - screenshot - Both these were on to 10.6.8
    – Old Pro
    Apr 21, 2012 at 16:24
  • How strange, I downloaded the installer from TrueCrypt again to be sure and it still tries to install MacFuse - I'm also on 10.6.8. Though As I've mentioned above I now believe it to be a problem in opening containers created on windows (FAT16) - do you work with those on TrueCrypt?
    – Rory
    Apr 21, 2012 at 18:47
  • I don't know what you mean by FAT16. My Mac (with OSXFUSE installed) can create and read/write FAT32 and ExFAT partitions. Check for yourself using Disk Utility to create a new disk image. Go ahead and install OSXFUSE independently, then re-install TrueCrypt. I did a relatively clean install to get my Mac from OS X 10.5 to 10.6, and it's possible I had some FUSE drivers copied over or installed by something else, but I think the FAT drivers are native and the ExFAT drivers came from TrueCrypt.
    – Old Pro
    Apr 21, 2012 at 20:14

The OSXFuse website FAQ (https://github.com/osxfuse/osxfuse/wiki/FAQ) says this about MacFuse: "The latest release does not fully support Mac OS X 10.6 and will not work at all on OS X 10.7 and later versions".


I had similar problem few days ago, not related to TrueCrypt though. I've also tried few different version of MacFuse and finally end up replacing MacFuse with OSXFUSE that works well so far. And by the way, I discovered that MacFuse is no longer maintained and considered dead.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .