I have just tried to rent Iron Man, first on my MacBook, but then for some reason the AirPlay button dissapeared when I tried to AirPlay it to my new Apple TV. So then I just decided to rent it straight on the Apple TV (3rd gen) and I had 2 free rentals from a previous problem, the rental on the MacBook used the first credit, and bizarrely the rental on the Apple TV used the 2nd, so I guess I would have been charged twice.

But now, after all that, it says ready to play in 8 hours 40 minutes. Which is quite unacceptable. When I was renting on my Macbook the total download time was around 8 hours. But I could start playing after about 15 minutes and it would download in the background.

Does the Apple TV not allow buffering, and require the whole movie to download before it allows you to start playing?

I'm really hoping I've missed something, because I'm beginning to wish I'd bought a Media Center PC.


Apple TV only does buffering, there's no hard drive to save stuff onto. It does not have to download the entire thing, but if your connection is really slow, it will have to buffer a ton more in order for it to play. It's not perfect, but it is pretty good at guessing how much to download before it starts.

  • Ok so then why is it trying to wait for 8 hours, when 8 hours is the length of time to download it completely. I've set the Apple TV to SD, and my connection fluctuates from 100Kb/s to 3.5Mb/s – Jonathan. Apr 9 '12 at 20:38
  • If your connection rate fluctuates, this explains why it wants to buffer a considerable amount before allowing the playback to start. – EmmEff Nov 3 '12 at 22:03

Do you have any special DNS settings configured on the AppleTV? Sometimes services such as GoogleDNS and OpenDNS can cause problems interacting with the iTunes store.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .