4

My meetup.com account allows me to subscribe to an iCal calendar that displays all meetups that I have RSVP'd "yes" to.

All of the events appear as expected, but none of them have an alert setting (e.g., display message 2 hours before).

Is there a way to set an alert for events in a read-only subscribed calendar?

2
3

My workaround, annoying as it is, is to copy the subscribed event to my main calendar and set my alerts from the copy.

1
  • Very annoying! But apparently the only workable solution :S – Juan A. Navarro Oct 4 '13 at 10:37
1

As of iOS 13, Calendar's Default Alert Time setting will be used to for alerts in the external calendar subscription.

  • Before subscribing to the external calendar, go to Settings > Calendar, tap Default Alert Times and select the desired alert (in user5118's case, "2 hours before")
  • Subscribe to the external calendar as usual

To change the alerts for a subscribed calendar (e.g. from "None" to "2 hours before"), unsubscribe from the calendar, change Calendar's Default Alert Time as described above and then re-subscribe. To unsubscribe from a calendar:

  • Go to Settings > Passwords & Accounts > Subscribed Calendars
  • Tap the calendar to unsubscribe from and enable "Remove Alarms"
  • Tap "Delete Account", and then tap "Delete Account" again to confirm
1
  • it is simple, but I spent much time to get this answer, thanks! – netawater Mar 1 at 5:16
0

I don't believe it's possible to add data/information to a subscribed .ics calendar. I've tried to make it work here using a calendar I'm subscribed to and my only option is to view the event.

Even if I try to delete an individual event within the subscribed .ics calendar I'm presented with a dialog saying You can't change items in calendars you subscribe to.

If you are sent an invite by someone then you can set an alert for that event.

If Meetup.com allows you to set an alert in the subscribed calendar that may be your only option.

0

@ M.W. There is a another way.

In the Calendar app on our Mac go to Preferences. Select "Alerts" Select the "Account" you want to modify alerts for. Choose an a selection for "Events", "All Day Events", "Birthdays"

You will see that "Use these default alerts on this computer only" is greyed out. That is because these are per-device/local setting.

Now every event in your calendar will be updated with those alert settings.

Another option is to download the Google Calendar app and allow it notify you for only those events.

-2

You can Control click on the calendar in iCal and go to Get Info and enable 'Ignore Alerts'. I'm not sure if this preference syncs with the iPhone too, but it certainly works on the Mac.

3
  • He's looking for a way to add an alert to a subscribed calendar event, not a way to disable all alerts for the calendar. – Tuesday Apr 9 '12 at 10:54
  • Well, isn't that as simple as making sure that 'Ignore Alerts' is disabled? – Vidur Apr 9 '12 at 19:08
  • That's wrong on two and a half levels: 1) you refer to enabling "Ignore Alerts", not disabling it. 1.5) The events would need to already have alerts, which they don't. 2.5) He's subscribed to it, so he can't add an alert with the native method. – Tuesday Apr 9 '12 at 22:27

You must log in to answer this question.