I have installed the beta of messages. I understand the software is beta and I have searched all the Apple messages forums and Google around for a solution but could not find one.

I have set messages to launch upon startup via the icon in the dock as follows:

enter image description here

However when I log into OS X Lion 10.7.3 the primary new message window pops up:

enter image description here

This has the effect of having the messages icon in my dock active in addition to having a new message windows pop up.

My desire is to have messages start up without having a new message windows open upon login. Is there an obvious way to accomplish this? I have tried using minimize scripts which minimize the new message window but still results in having two icons active in my dock as follows:

enter image description here

I have additionally made sure that the "Restore windows when quitting and re-opening apps" setting under general preferences is not on.

1 Answer 1


You can create an AppleScript to do that for you.

  1. Open AppleScript Editor
  2. Type/paste this in:

    tell application "iChat"
        set minimized of window 1 to true
    end tell

launch "iChat"
tell application "iChat"
    close window 1
end tell
  1. Save as an application somewhere
  2. Open System Preferences > User/Accounts > Login Items
  3. Click Add, navigate to application, add and enable
  • Wouldn't it be tell application "Messages"? Or is the name still "iChat"?
    – daviesgeek
    Apr 9, 2012 at 16:29
  • The app is still called iChat for some reason? Probably will be changed once the software comes out of beta. @Vidur Murali, I tried your solution and it does what you indicate but it turns out my question was not clear enough as to what I was trying to accomplish. I have clarified the question with additional screen shots and information.
    – Mort
    Apr 9, 2012 at 16:59
  • @daviesgeek The beta Messages is still called "iChat". It took me a second to figure out too when I couldn't find the .app file.
    – Vidur
    Apr 9, 2012 at 19:11
  • Ok. I wasn't sure if it actually was changed to "Messages" or not.
    – daviesgeek
    Apr 9, 2012 at 19:13
  • @Mort I understand what you're trying to do better. The reason I didn't notice this is because I have my minimize preferences set to 'Minimize into icon' or something similar (I don't remember what the exact preference name is). So the script right now simulates clicking of the orange '-' button on the window. The solution would be to simulate clicking of the red 'x' button. Going to google around and be back in a bit with an edit.
    – Vidur
    Apr 9, 2012 at 19:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .