2

I'm on Lion and I like to use the multimedia Next Track, Play/Pause, and Previous Track keys to control iTunes.

Every once in a while, these keys basically stop working. Sometimes they just don't work and sometimes the action is delayed by minutes. I'll hit the key out of habit and then nothing will happen, so I'll go into iTunes and pause. Then maybe 5 minutes later, it will unpause (presumably because the key event finally made it to iTunes.)

Any idea what in the world is going on? The only thing that seems to fix it is a reboot (though a log out and log in might do it as well. Not in a position to try that at the moment.)

Argh! It just happened again. Super annoying.

3 Answers 3

2

I finally just figured it out! It turns out that I had a Quicktime process that was stopped (I had done an open on an avi file on the command line.) A kill -CONT on the pid allowed it to continue so I could close it and now I have my keys back!

3
  • any chance of explaining this in simpler terms? I have the same problem of delay with the transport keys but don't understand how you remedied it. thanks.
    – user34850
    Nov 16, 2012 at 15:13
  • Open up your activity monitor and see if quicktime is listed. If it is, stop the process. Nov 16, 2012 at 18:21
  • QuickTime Player 7 specifically is what was causing the problem for me.
    – sudo
    Oct 3, 2014 at 20:51
0

The problem for me seems to be caused by QuickTime 7 + OS-X 10.10.

But QuickTime seems to need to be running a while before there's any noticeable latency. And the longer it's running, the longer the latency in the processing of play/pause/skip by iTunes.

Running QuickTime 10.10 seems to completely disable the play/pause/skip processing - at least in some cases.

In either case the latency disappears as soon as QT is terminated.

-1

I fixed my delay by running this command in terminal:

/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -seed -r -f -v -domain local -domain user -domain system

This function resets user domains. Reset Launch Services...

http://ss64.com/osx/lsregister.html

2
  • 1
    Could you explain why and what it does
    – mmmmmm
    Jun 15, 2015 at 12:11
  • I updated the response to include the answer, Mark Jun 18, 2015 at 3:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .