22

I have 13" MacBook Pro (Late 2009) model that is refusing to play sound on the right audio-channel.

Without any speakers connected it still plays fine but once I connect earbuds or a headphone, I only have sound in my left ear. In my right ear I hear a very low white noise sound.

I've tried rebooting, fixing disk permissions (very long shot, I know), same problem if I play sound in a virtual windows machine. And off course I've verified that the sound balance is set to both left and right.

I've "looked" into the mini-jack output but can't see anything wrong with it...

1
  • Have you tried other headphones? It could be caused by a bad cable.
    – Toby
    Sep 27, 2012 at 7:12

5 Answers 5

4

It is probably some dirt in- or another problem with your sound-output jack.

If twisting your headphone-cable or repeatedly plugging it in and out of your MacBook does not work, you might fix it by doing something like (gently!) poking into it with the backside of a matchstick or trying to clean it with some cotton buds. In that case make sure you have one that does not fall apart easily or you'll end up with a cotton-filled connector.

If that does not work, I'm not sure if you are able to fix it yourself since your MB might need to be taken apart to get into the jack and clean it…

3
  • I suggest using compressed air rather than wedging anything in. Compressed Air is available at Tech Stores like Best Buy and Radio Shack.
    – ICL1901
    Aug 4, 2012 at 3:22
  • Blowing compressed air in it didn't help either, ended up taking it to my local Apple dealer and they had to replace the motherboard. Aug 6, 2012 at 13:16
  • 1
    How much did that cost?
    – Toby
    Sep 27, 2012 at 7:13
44

Check your settings in System Preferences > Sound > Output.

I had the same problem and for some mysterious reason my left-right balance was completely screwed up.

No idea how it happened but once I adjusted it to center it now plays back perfectly (:

7
  • 1
    Yup .. this was the problem for me too. It does not help that this seems to affect only the earphones/headphones and not the MBP speakers. Apr 28, 2013 at 14:30
  • Hmm .. I figured out that this happened because I had Boom installed to boost the MBP volume, and in System Preferences -> Sound -> Output, it was for 'BoomDevice' that the balance was askew. Apr 28, 2013 at 14:32
  • I had the same problem (only right channel working). By only opening the menu you said fixed the problem. The balance was centred, but now it actually plays correctly. Mystery...
    – Atcold
    May 18, 2015 at 6:08
  • this was the issue for me, i thought it was my bluetooth headphones on the fritz, but it was actually just the left-right balance
    – worc
    Aug 10, 2016 at 17:30
  • you are a lifesaver. i was panicking. i was seriously panicking. i can't lose this machine for weeks on end. tried looking at audio+midi options and the balance was right. went into output -> the balance was weirdly to the right. .. thank you for the the release from a constricting choking feeling of hopelessness.
    – esaruoho
    Jan 15, 2019 at 18:46
16

This is also a long shot, but check under System Preferences -> Universal Access -> Hearing and see if "Play stereo audio as mono" is checked.

Hearing properties

One other possibility: plug your headphones in and run Audio MIDI Setup (it's in Applications/Utilities). See if one of the output channels is turned down or muted. Be sure your headphones are plugged in because OS X has separate settings for headphones and built-in speakers and switches between them automatically.

Audio MIDI Setup screenshot

0

If you find that the headphone channel is blown, a workaround I have used is something like this: Sound Blaster X-Fi Go! Pro

These types of devices use USB rather than your headphone port. They also produce great sound.. Several companies make these kinds of products and they are fairly cheap.

Hope this helps

0

Thought I would answer here as I had the same thing on my old macbook and now on my new one.

And it happened all of a sudden.

Looks like my sennheiser headphones somehow sets the balance to left after pulling the headphones out.

Go to sound settings and set the balance to the middle, assuming its on the left.

Otherwise hardware issue, which I doubt.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .