1

I'm visiting my relatives and trying to get my MacBook on their network. If I connect over Ethernet, everything works fine and I can get online without a hitch. But if I connect over WiFi, I can't actually get on the Internet.

In System Preferences > Network, under AirPort, it says that it's using a "self-assigned IP address" and "will not be able to connect to the Internet." Furthermore, under Advanced > TCP/IP, the settings don't look correct when I compare them to the other computers in the house - the format of the IP address is different, the subnet mask is different, and the IP address of the router is blank.

I've tried copying the settings when connected over Ethernet (IP address, etc.) to use as manual settings for the WiFi, and it still doesn't work.

Other than this MacBook, there are two Windows laptops and two iPhones in the house (one theirs, one mine), and all of those other devices can get on the Internet over wifi with no issues. I'm stumped!


UPDATE: I never solved this, but the situation recently came up again – this time with a totally different computer – and I had the same exact issue: connects to the local network without a problem, but no Internet connection. So that tells me it's something wrong with the network/router, not the computer, but I still don't have any idea what it could be.

  • Can any other computer connect via Wifi? – user151019 Mar 28 '13 at 13:39
1

Under System Preferences > Network, choose AirPort, click on Advanced, select the name of your wireless network and click the - button to remove it. Turn AirPort off, wait a few, turn it back on, and try reconnecting to it.

You might also want to open the Terminal up and run the command:

dscacheutil -flushcache

Failing that, create a brand-new user account on the MacBook, log into that account, and see if it can connect.

  • No good on all three counts: removing and re-adding the network didn't work, the Terminal command didn't work, and it can't connect on a new account. – daGUY Apr 6 '12 at 17:48
  • Have you tried the good ole SMC reset? After that I'd say boot from a known-good OS (ie, target disk mode off another Mac), or reinstall the OS. – da4 Apr 6 '12 at 18:22
  • Also FWIW the dscacheutil -flushcache command doesn't produce any output whatsoever. – da4 Apr 6 '12 at 18:22
0

Go to Preferences → Network → Wi-Fi → Advanced → DNS and remove any previous DNS servers that were listed. Apple then automatically sets default ones or uses the ones provided by your network.

I think the flush dscacheutil does not flush any old DNS name servers and inhibits Internet access.

0

Maybe there is more than one WiFi access point, and the one you are connecting to is a dead end. For example, maybe your relatives put in a "range extender" and you're connecting to the extender... but the extender is not connecting back to the main router. In that case, I would skip the extender by bringing my Mac closer to the main router, turning WiFi off, and then on again in hopes of joining the network using the main router. (Or unplug the extender and then join the network.)

If you hold the Option key down while clicking the WiFi menu you will see a lot of extra information, including the BSSID. That number is the ID of the base station you are connected to. You can find the number of a base station on the bottom if it's an Apple Airport. So, if there are two Airports, for example, and one of them is supposed to get its connection through the air from the other one, and you are wondering which one you are connected to, the Option-click on the WiFi menu will tell you.

If there is an extender (or an Airport trying to reach to the main Airport) and it's a dead-end unplug it until you can reconnect it to the network.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .