Performing the EFI firmware update to version 2.7 these days, I noticed that my 15" MacBook Pro (bought March 25, 2012) resets for five times before booting effectively.

Even then, I can notice that EFI firmware 2.7 is still available in Software Update.

I tried to repeat the update operation, but still no joy. It seems like the update couldn't take place for some reason.

I can't figure out why.


Sometimes 'Software Update' fails and you are stuck with an incomplete update if this happens you can try to download the update as package direct from Apple (MacBook Pro EFI Firmware Update 2.7)


Install the package, maybe this will fix the problem.


On portables, firmware update will not run unless the machine is connected to AC power



Are you using 10.7.4? I have the problem on 10.7.4 (11E35 developer release). I suspect when the consumer release is available the EFI Update will stick.



The problem was due to broken filesystem permissions which were preventing the system from applying the update.

Once the permissions have been fixed using Disk Utility, the update took place like a sweet.


I had the same issue. For me it turned out to be something different. The EFI parition was broken:

Trying to mount the EFI parition (check with diskutil list!)

sudo mount -t msdos /dev/disk0s1 /Volumes/tmp

resulted in (dmesg)

mount_msdos: Unsupported sector size (0)

I recreated the file system with

sudo newfs_msdos /dev/rdisk0s1

Warning: Running the newfs_msdos on the partition will destroy all data on it. Only do it if you are sure what you are doing.

  • What did you do to solve the problem? Can you please add this to your answer to make it more useful for others?
    – nohillside
    Feb 22 '13 at 10:39
  • 1
    Somehow stackoverflow used an older version of my draft.. no idea why. It is updated now
    – plaisthos
    Feb 22 '13 at 11:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .