5

YouTube has a pretty decent mobile website, however any link to YouTube I see on the web always opens the link in the YouTube app, not there in the browser.

Is there a way to change that? It would be nice not to have to keep switching apps all the time. I checked in Settings and couldn't see anything. Echofon actually does it in its built in browser so I'm sure it must be possible.

  • Does "Open in New Tab" not work? I'd test it, but I'm not able to at the moment. – Timothy Mueller-Harder Apr 6 '12 at 0:21
  • @timothymh No, when I press and hold the URL, the only options that come up are "open in YouTube" and "Copy". – DisgruntledGoat Apr 6 '12 at 12:20
  • How about "Copy" and then going to that URL directly? – Timothy Mueller-Harder Apr 6 '12 at 22:26
5

Go to Settings > General > Restrictions and untick the Youtube button. After that Youtube links will open in Safari and the app icon will disappear from the home screen.

  • Thanks! I forgot I'd asked this question - I'd actually found this exact solution elsewhere. – DisgruntledGoat Aug 10 '12 at 9:09
1

You can also manipulate the URL to solve this problem.

By directing away from www and towards m, this video link shows what to change:

:)

0

This doe not seems to be able to fix via a simple setting or something. This topic at iMore says it used to be a beta-feature that has been taken out.

Appearently it has been asked at StackOverflow before, and in that topic it was suggested to edit the URL manually:

0

Okay so I found a fix that seems to work. You go to a new tab in Safari and paste this: https://m.youtube.com

Then it will take you to the app. Close the app, go back to Safari and enter the link again. A pop up will come up asking if you want to open it in the app. Click cancel and then enter the link a third time. YouTube should load and work like normal on safari. Hope this helps!

-2

Disable youtube app background refresh

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .