4

I'm trying to move files around in Finder by using my trackpad to drag and drop files. The problem is that I'm using tap to click with dragging enabled. So, when I decide to drop the files onto a folder, there is a brief delay between when I release the trackpad and when the files actually get dropped. (This delay is in place in case the user wants to temporarily lift their finger and tap-and-hold again to move the dragged items again.) During this brief delay, what often happens is that the folder I am hovering over is automatically opened up into a new window, and the file is not necessarily dropped where I originally wanted it to be dropped.

This automatic window opening can easily be seen by doing the following:

  1. Launch Finder
  2. Drag a file onto a folder and don't let go until a new window pops up.

I never need to use this auto window popup feature, so the simplest solution seems to be disabling this feature. Is there any way to do that? If not, do you have any recommendations as to the best way to resolve this issue?

  • Another option would be to turn on drag lock, which requires that you tap once when you are done dragging instead of using a delay. – ughoavgfhw Apr 4 '12 at 23:05
  • On which OS is that...not on my 10.11.6 – Frank Van Hoorick Apr 18 '17 at 15:50
5

You can disable this in Finder's preferences by unchecking "Spring-loaded folders and windows":

1

In Sierra, the "Spring-load" option is no longer in this location. It is found in System Preferences, Accessibility. Uncheck it. Otherwise, folders open and you have to manually close them.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .