This happens on both my MacBooks running 10.7.3 and has done at least since 10.7 and with iCloud. My calendar seems to work fine from my iPhone.

This popup says "Access to account “iCloud” is not permitted." and gives the option to "Go Offline" or "Ignore" and if I ignore is seems to be fine for a while and then it comes back after a few hours.

I also have an Exchange calendar and some subscriptions but this error always reports as being from my iCloud calendar.

Any ideas how I can fix this?

11 Answers 11


This problem appears to be caused by corrupted Calendar caches and it occurs in macOS 10.12.2 Sierra as well.

The easiest way to get rid of this problem is to:

  1. Quit Calendar
  2. Open Activity Viewer and Quit "CalendarAgent"

note, using QuickLook on any calendar item in the Finder will relaunch CalendarAgent which needs to be not running at step 3

  1. Delete ~/Library/Calendars/Calendar Cache
  2. Delete ~/Library/Calendars/Calendar Cache-shm
  3. Delete ~/Library/Calendars/Calendar Cache-wal
  4. Launch Calendar

                      Calendar data folder in Library under user's Home directory showing 3 Calendar cache files to delete as listed in the instructions

Calendar will read the information from the surrounding data folders and files in ~/Library/Calendars/ and recreate the caches cleanly.

If for some reason the files listed to delete re-appear before you launch Calendar, it means something is triggering the system calendar operations. Try quitting all of your applications and starting at step 2 or logging out with the "Reopen windows when logging back in" unchecked, then logging back in.

                  dialog window showing logout options, with "reopen windows when logging back in" unchecked


The ics file has an organizer line. Per the rfc2445 standard, Section 3.5 - Security Considerations, non event owners are NOT allowed to modified the event... hence the reason for getting the CalDAVWriteEntityQueueableOperation error.

Removing the entire ORGANIZER line from the ics file before importing fixes the issue.

Per the standard, if the event is not on a group scheduled calendaring system,e.g. a single users calendar system, the organizer's line MUST NOT be specified (section - Conformance).

Amazing how many webinar companies get this wrong....

  • Thanks, this is what the issue was for me. I was generating ICS files that were constantly showing the OP's error and removing the organizer entry solved it. Aug 16 '15 at 0:53

I previously had a similar issue when migrating multiple accounts from MobileMe to iCloud. I resolved the issue by disabling and then enabling iCal sync through iCloud on my iMac in System Preferences -- actually I believe I disabled everything in my case.

Always backup your calendar before troubleshooting (File > Export > iCal Archive).

The following steps are roughly from a Apple Support Community discussion.

  1. Open iCloud in System Preferences.

  2. Switch off (uncheck) iCal sync in iCloud System Preferences pane.
    Backup iCal before doing this. You will need to remove calendar data.

  3. Open iCal and verify the iCloud account is removed in the iCal preferences under accounts.

  4. Close iCal, reopen System Preference and switch on (check) iCal sync in iCloud System Preferences pane.

  5. Reopen iCal and verify the iCloud account is enabled in the iCal preferences under accounts.

At this point if the problem persist I might try completely signing out of iCloud and then signing back in. But remember to backup all related data before turning off iCloud sync - iCal, Contacts, Mail, Photostream, etc...

  • I ended up trying the iCloud complete logout. After logging in again, iCal started repopulating events from the cloud, but then after everything appeared the same message showed up again :( Apr 15 '12 at 19:23
  • You can try the following. Remove user information, caches, calendars, plists. 1. Sign out of all iCal and iCloud accounts. 2. Open Finder, click on Go -> Go To Folder…, and type '~/Library/`. 3. Move contents of Caches folder, iCal plist files in Preferences folder, and contents of Calendars folder to the Trash. Add user account information. 1. Restart computer. Enter iCloud account details in System Preferences. 2. Open iCal and verify all calendars have loaded and no errors occur before adding additional accounts to iCal. e.g. Exchange Apr 18 '12 at 0:23

Perhaps this might get solved if you add you iCloud credentials to your keychain? I had a problem where Mail kept prompting me for the password even though I had the 'Remember Password' setting enabled in Mail. It got resolved when I explicitly added the login details into Keychain.

  • Thanks Vidur! Any idea what the "Keychain Item name" should be? "me.com" or "icloud.com" or something else? I'm not sure how I can manually associate a new keychain item with iCal.app though... Apr 10 '12 at 6:41
  • Here's what mine looked like, I can't remember where I got the 'Where' field...probably some forum or somewhere. cl.ly/0L1s1S0g3F0h3Q1z0W0Y
    – Vidur
    Apr 10 '12 at 14:39
  • Thanks - and very interesting. I found an entry on one computer with something similar - just the number in Where was different. On my primary computer, however, there are no CalDav entries at all, but iCal works better on that machine.... Apr 11 '12 at 9:05

This problem was solved using Dale Fosters library trick. I disabled the calendars, backed up and then moved ~/Library:


…to the desktop. Then reenabled iCloud Calendars in preferences. I had to reenter account info in Calendars, now everything is working as it should. Thanx!

  • Unbeliveable. Yesterday I tossed away the .plist etc, and successfully merged two calendars via import. Today, Calendar.app decided my doings of yesterday was invalid. and once again (this was the status previous to my preference trashing) threw the 403 error on every imported item. False thumbs up, sry.
    – bonka
    Nov 23 '12 at 15:15
  • When you say you moved them to Desktop - that was just as a backup? You then trashed those files/folder because Mail.app rebuilt them? Dec 5 '13 at 3:41
  • Neither files exist on my system under macOS 10.13
    – Cerniuk
    Oct 6 '17 at 17:26

The last time I got

The Server responded: "403" to operation CalDAVWriteEntityQueueableOperation.

I looked above the server responded and found under

"The server responded with an error."
Access to (in my case it was)
"Spring: Boston 5 - St. Louis 3" in "Unexpected " in account "iCloud" is not permitted.

So, I selected Go Offline, clicked on my Calendars, unchecked all the calendars, except the one I had named Unexpected, and searched in iCal (upper right corner) "Spring:". What I discovered was last year's baseball schedule. I deleted all 181 entries, quit iCal, then reopened iCal, and everything was fine.

Well that's my experience.


I had one calendar entry that was a problem. I created a new calendar. Changed the entry to that Calendar and then deleted the calendar. Issue fixed.


I copy and pasted the event and changed the calendar to the same calendar (this time a little icon of a person appeared next to it). After clicking send and ignore a few times, all is ok.


Because the item was in iCloud's calendar server, I simply logged into the icloud.com (or mac.com) website and deleted the calendar event there. No complaining from the server and the item immediately disappeared from my Apple Calendar app.


I realized that all error messages were linked to my Google account. So I went to mail preferences and in accounts, and I checked the details/info in my Google email. All the error messages I had seen before were linked to this email account, so if I unchecked this account on iCal, all its notes would disappear and therefore all the error messages.

But, I wanted to remain with notes. I could just put the notes under the other email account, but I did enter the password again and since then I don't have problems anymore.


I personally, just kept pressing on the OK (or Close, or Cancel, or Try again) button (don't remember exactly the label of the only button in that dialog box) for like 20 times, until it fixed itself.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .