I am accessing my colleague's work email account (on gmail) using IMAP. The problem is that whenever I read one of the messages first, it is marked as read on the server and he often misses it. I would like to keep it unmarked on the server and mark it as read only at my Mail app.

Is there any way how to setup Mail app so that this behaves like this?

I am accessing his email because he often gets information that is important for me as well and this saves time because he isn't always online and he would have to forward most of it to me anyway.

7 Answers 7


This mechanism is a feature of the mail protocol that you are using, and isn't a local feature that you can choose to set within Mail. You are likely useing either IMAP or Exchange, the the replication of mail states for things like location, unread/read etc is a part of the normal operation.

I am not at a Mac, so I cannot test for features, but the best you can hope for is a configuration in Mail that will allow you to either change what action marks the mail as read or not (Might be mere selection, might be opening the time specifically, might be viewing the message for more than X seconds etc) or extend the time that it takes for the action to complete (viewd for 5 seconds, or 10, etc).

You can of course simply right click on a read mail and then mark it as unread again.

  • Thing is, I want to have them read on my machine, but not on the server. I suspected that the protocol is the problem, but I was unable to change it
    – Lope
    Apr 3, 2012 at 12:40
  • @Lope "thing is, I want to have them read on my machine, but not on the server." You cannot with IMAP. That's the protocol. It syncs local content with server content. Look to using POP3 if you want to keep discontinuity between the server and your local copies.
    – user10355
    Apr 3, 2012 at 18:45

There is a free program called True Preview that you can install to prevent Mail from automatically marking messages as "read". We use this all the time because we want messages to remain unread until such time as we actually mark them as "read". True preview has options to have different settings for different accounts, which is useful.



The mail client in Opera has this feature. I have "Mark as Read" set to "Manually" and email that I have not viewed are shown in blue text and after I viewed them they are shown in black text. And they stay unread.


The workaround is to change the number of seconds required for the mail to be marked as read. The default value is 2.

Please type the below command in terminal and it should do the trick. Tested on Big Sur (11.2.3)

defaults write com.apple.Mail MarkAsReadDelay 0
  • I'm using Big Sur and this doesn't do anything even after re-opening the macOS Mail app.
    – TheZeke
    Apr 19, 2022 at 18:05
  • @TheZeke : Have you tried with a longer number (say 10s or 15s) and check that it takes longer time to mark the email as read? At least we could be certain that the command works.
    – satishffy
    May 4, 2022 at 21:56

This is how IMAP works.

Another solution to your problem is to set up Gmail to send you a copy of every message from your co-worker's account.

Otherwise you will have to set each message you read on his account to Mark As Unread.


As other answerers have described, this is a feature of IMAP. IMAP maintains client-server synchronization so you will see the same thing regardless of whether you are using the browser, your desktop or your phone.

An alternative is to use POP, which is a one-way download of messages. You will not benefit from any server-side filtering/labeling you have implemented in the Gmail UI, but your messages will have a unique read state on each device and will remain unread in the Gmail UI or in your colleague's email client. Please make sure that you properly configure POP inside of Gmail to keep downloaded messages in the inbox -- note that Gmail is unusual in that this setting is controlled inside of Gmail on the Forwarding and POP/IMAP tab of Settings, rather than in your email client.


I had same issue, the culprit was the iPhone's email client with its default preview feature. A preview fools the IMAP to believe it's read. Solution: to switch it off (go to settings -> email -> set preview to none.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .