this is my first question here so go easy on me. Truth to be told it's not really a question, more like a curiosity.

I noticed that after prolonged use of my 1st generation iPad without rebooting it (shutting down & turning on) some games started acting wonky. The first problem was with iBomber Defence Pacific which started crashing in the transition menus (thankfully not in the game). After a while I couldn't enter the game at all as it was crashing constantly. I got quite frustrated but I left it as it was...

Then I purchased Angry Birds Space and I noticed I couldn't pause the game. So I googled my problem and someone suggested to reboot the iPad.

And bam, that solved it. But the question is why? I mean, I periodically manually close the running apps and as much as I know this clears them out of the memory. Is there a bug which leaves stuff sticking around which slowly but surely clog the device's RAM?

Just wondering... :)

1 Answer 1


Most probably it was that rebooting your iPad reinitiated the memory. The thing is some apps have poor memory management schemes. So due to those bad "memory dumps" you device's memory becomes used for nothing. So When you reboot the device, the problem is solved

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .