0

I am trying to restore my MacBook Pro 2023 after wiping out the SSD contents while trying to uninstall Asahi Linux. I am following the Partitioning cheatsheet.

I went into the burden of installing idevicerestore in both another M1 Mac and Ubuntu and I am getting the same result. All goes well until it waits for the Mac to boot, the mac never boots and eventually times out:

Sending iBEC (887516 bytes)...
Waiting for device to disconnect...

I have found that if I just power off and on with the magic keys again, it detects it and it's able to proceed.

But apparently, the problem is still there (the full debug output is below) :

Recovery Mode Environment:
iBoot build-version=iBoot-10151.121.1
iBoot build-style=RELEASE
iBoot boot-stage=1
ERROR: iBoot should be at boot stage 2, continuing anyway...
radio-error=1
radio-error-string=1
Sending RestoreLogo...

Obviously, I have tried the official procedure (also mentioned in the cheat sheet) but it fails with Unknown Error(21) more details can be seen at Somona won't install even in DFU mode. The Mac “Mac” could not be restored. An unknown error occurred (21).

Also, I started that whole process as root and usbmuxd as running all the time on Ubuntu and macOS.

Any idea what's going on? I can't believe a blank hard disk is capable of bricking a laptop :(

I am also providing my logs on Pastebin.

2
  • DFU mode as in support.apple.com/en-us/102662. Note you have Apple silicon and not T2 - the correct instructions are slightly different. Failing that, take it to an Apple Store (make appointment first) and they will restore macOS like on a new MBP (probably for free).
    – Gilby
    Commented Jul 6 at 4:13
  • Yeah, since that is failing I’ve ran out of options. I’ve found a threat with exactly the same issue on m1 and the guy solved it by trying different cable+ and rescue host. I will try that before Apple Store. Commented Jul 7 at 15:33

1 Answer 1

0

I’ve found out what I was doing wrong. TL/DR; I was putting the laptop in Recovery mode because I was following apple’s intructions which assume you can boot into recovery, which is not the case when you wipe the hard drive. But this gentlemen has the correct procedure, and it worked like a charm.

I hope this helps anyone else out there, it’s worth to watch : https://youtu.be/q-FsB2onSx0?si=5MgLsWokeCyDG-Qe

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .