1

I have a M2 Max 32GB 2023 macbook pro. It is displaying 8GB of physical memory inside activity monitor. The full allocation of RAM is not being shown or used. I may have set a limit on accident in terminal. Hoping to try and remove this limit on the available RAM. I work mainly with node and React front end applications.

***Also went to apple store yesterday and tests were ran against the RAM. No issues found, tech created a new Admin user with fresh settings and it shows the full 32GBs for that user.

Top Command from Terminal

Processes: 432 total, 3 running, 429 sleeping, 4341 threads                                                                                               11:26:59
Load Avg: 1.94, 2.31, 2.62  CPU usage: 4.93% user, 4.3% sys, 91.3% idle    SharedLibs: 679M resident, 124M data, 43M linkedit.
MemRegions: 1388752 total, 7249M resident, 198M private, 2351M shared. PhysMem: 31G used (2456M wired, 17G compressor), 105M unused.
VM: 279T vsize, 4285M framework vsize, 112840(0) swapins, 495532(0) swapouts.  Networks: packets: 2525788/1621M in, 1496892/303M out.
Disks: 5259060/154G read, 2637509/111G written

ulimit-a Command

-t: cpu time (seconds)              unlimited
-f: file size (blocks)              unlimited
-d: data seg size (kbytes)          unlimited
-s: stack size (kbytes)             8176
-c: core file size (blocks)         0
-v: address space (kbytes)          unlimited
-l: locked-in-memory size (kbytes)  unlimited
-u: processes                       5333
-n: file descriptors                256

Don't want to make things worse but I'm sure I need a terminal command to reset this physical memory limit for the RAMactivity monitor

New contributor
Chris Kim is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
15
  • That for sure looks odd. Assume a reboot didn’t solve the problem? Can you run top in Terminal and add the top 4 lines to the question? If you boot into Recovery, how much RAM do you see there?
    – nohillside
    Commented Jun 11 at 5:55
  • What does "About this Mac" tell you regarding the RAM capacity?
    – X_841
    Commented 2 days ago
  • Reboot did not solve the problem, Top command has been added. About this Mac shows 32GBs of RAM
    – Chris Kim
    Commented 2 days ago
  • 1
    If you have narrowed it down to a user-account problem, then the solution can only involve some settings or parameters set for that account in ~/Library.
    – benwiggy
    Commented 2 days ago
  • 1
    You'll have to just test what happens when you remove plists from ~/Library/Preferences. (And log out and back in.)
    – benwiggy
    Commented yesterday

2 Answers 2

2

The comments and discussion following the question showed that the issue is that Activity Monitor is showing incorrect RAM usage for just one account/user. How this happened is not clear, but the solution is this:

  • Exit Activity Monitor,
  • Delete Activity Monitor's preference file ~/Library/Preferences/com.apple.ActivityMonitor.plist, and
  • Logout and login again.

Next time Activity Monitor is run, the preference file will be recreated with default settings and again show the correct RAM usage.

2
  • Thanks for the answer! Unfortunately it still showing 8gbs I have no idea what to do ugh.
    – Chris Kim
    Commented 4 hours ago
  • @ChrisKim Can you try again, and remove ~/Library/Saved Application State/com.apple.ActivityMonitor.savedState as well?
    – nohillside
    Commented 2 hours ago
1

This answer is not the right one for the problem that @Chris Kim has. But I will leave it here to show how maximum RAM to be used is set on a system-wide user-wide basis.

It is possible your hardware is faulty. But let's assume it is fine.

You have probably, at some time in the past, told your Mac to boot with reduced RAM. This is set in nvram. This is how I know to change it and is likely what you have done:

  1. Disable SIP and reboot.
  2. Use nvram boot-args to display what is in your boot-args.
  3. Use sudo nvram boot-args="maxmem=8192", and reboot.

To undo this you need to use:

  1. Disable SIP and reboot.
  2. Use nvram boot-args to display what is in your boot-args.
  3. Use sudo nvram -d boot-args to remove all boot-args, and reboot.

Is you wish re-enable SIP.

Some references:

Exploring Apple silicon

Turn off Memory is old, but answer is still correct if you disable SIP.

1
  • Thanks but followed the steps and still showing the 8GBs. I went to the apple store yesterday and ran tests against the RAM and all passed. Tech created a new admin user and the 32GBs shows for that user. So something has definitely been set for my current admin account.
    – Chris Kim
    Commented 2 days ago

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .