1

I'm helping a friend who has suffered a big loss of data. She keeps some Time Machine snapshots on an external drive but when we try to recover a file we get an error message "...some data can't be read or written (error code -36)". I've tried to perform a Disk Utility>First aid without any result. Do you know a way to make recovery work?

In case this is impossible: the Time Machine Backupdb is still useful to us to identify the files lost, all we would need is to list the files and folders in the backup. I've tried doing so using terminal to list the directory (ls) the Backupdb folder but it seems I don't have permissions for it. Here comes my second question: is there a way to list the files in a (unusable or corrupted) Time Machine backup?

I see I can get the list of files in a folder copying the files and pasting it into a text document, this work for a single folder but I have hundreds of folders and going manually through all of them is a titanic effort.

4
  • When you get the error message, how are you trying to recover the files: in the Finder, or through the Time Machine interface? Do you get the error with all files, or only one? What version of macOS are you running, and is it the same version that was used to make the backups?
    – Linc D.
    Commented May 31 at 17:17
  • @LincD. I try the recovery of a single file from the Time Machine interface, before the error, I'm asked to choose a destination folder because the original doesn't exist anymore. I don't know the OS version when the backup was taken, now we are running Sierra
    – naio
    Commented Jun 1 at 21:04
  • I'm still not sure about the extent of the problem. Can you restore any file from that snapshot to any location? If there are other files in the source folder, can you restore any of them to the same location? What about another snapshot? If everything fails to restore with the same error, you're likely dealing with a faulty drive or cable, regardless of what Disk Utility says.
    – Linc D.
    Commented Jun 2 at 2:36
  • Note that the -36 error is the same as from the classic MacOS days. What it boils down to is a premature end of file that you are trying to read. So whatever it is that you are trying to recover is not complete and/or damaged beyond the point that macOS can do anything with it. you could try running first aid in Disk Utility or perhaps a 3rd party disk repair tool (there are few, if any that work on APFS) if you can find one. But that error is difficult, at best, to recover from. Commented Jun 3 at 17:55

0

You must log in to answer this question.

Browse other questions tagged .