3

The image below is from version 10.12 of macOS, where the volume is in JHFS+ format.

Volume UUID of / shown in System Information

This same UUID can be obtained by entering commands in a Terminal application window, as shown below.

$ diskutil info / | grep "Volume UUID"
   Volume UUID:              3B553422-24F6-3FC5-B35F-EB8B2AAD8FDB

How can I modify the UUID, when the version is macOS 14 and the volume is in APFS format? I tried using apfs.util, but the modification of the UUID does not take effect.

7
  • Like you, I tried using apfs.util and could not change any UUIDs. Commented May 31 at 8:01
  • 2
    Why do you want to change the UUID - I thought that the idea of a UUID was that it was unique and does not matter what it is
    – mmmmmm
    Commented May 31 at 9:44
  • Because Apple verifies it, and I use VM cloning, but it won't change Commented May 31 at 10:29
  • 1
    @special_mkbk Apple "verifies" it? Commented May 31 at 15:02
  • @MarcWilson: Are you saying the OP should have posted the UUID as text instead of posting an image? Commented May 31 at 15:22

1 Answer 1

1

I still have not found a way to do what you are asking. After some thought, I realized there probably would never be a need to do so. I do not think one could never mount the same snapshots with the same UUID on separate volumes at the same time on a Mac. Two APFS volumes could contain the same snapshot, but only one snapshot could be mounted as /. The other APFS volume could be mounted, but the volume itself would be mounted and not the snapshot. What is the reason you are trying to do what you ask in your question? I was able to do a VM clone where the UUID of each APFS volume changed. However, you are trying to change the UUID of a snapshot, which did not change when I cloned the APFS container. To me, this is correct behavior. The UUID of a snapshot should not be changeable.

4
  • Hello, hfs.util cannot run on OS14. OS14 is in APFS file format Commented May 31 at 5:58
  • What I want to inquire about is how to modify the OS14 system Commented May 31 at 5:59
  • And the modification of uuid by apfs.util does not take effect Commented May 31 at 6:02
  • special_mkbk: Based on your previous comments, I completely changed my answer. Commented May 31 at 19:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .