1

Sonoma 14.4.1 on MacBook Pro M1.

Spotlight (cmd+spacebar and from the menubar) cannot find any file. It only finds (sometimes) the apps in the /Applications folder. Correspondingly, search in Mail also does not work. Only search with Finder can find files.

Before you answer with ideas let me tell what I tried, with temporary and/or mixed success. (All that follows, in various combination and alone)

  1. sudo mdutil -X / and mdutil -E /
  2. sudo mdutil -i on and then off
  3. reboot
  4. create new account and see
  5. kill and restart the processes corespotlightd and Spotlight
  6. check in syslog and other logs to see if there is any clue. Nothing obvious.
  7. also add and then remove the whole disk, or only my own home directory, in the "Privacy" in System setting.
  8. reinstall all of Dropbox, OneDrive (just in case!)

Sometimes, after (1) I get some hits for a few minutes and then it is all again back to zero. Sometimes after (5) I get some hits and after a few minutes back to zero.

Sometimes it seems to be indexing after (1), but most of the times nothing really happens.

I can't upgrade because policy administration prevents update (but I do have admin access to the computer, so I can run sudo).

I am running out of ideas.

6
  • Does the shell command mdfind work as expected? If not, please post the first few lines of output from a sample search.
    – Linc D.
    Commented May 31 at 3:58
  • Yes, it seems to work fine. That's something at least. But the GUI returns nothing. (of course all is checked in the "Siri & Spotlight" "Search Results")
    – Maber
    Commented May 31 at 4:50
  • Do you have any crash logs in Console.app, did you try sudo mdutil -Ea, does your mdutil -sav look normal (having Indexing enabled/disabled. messages), and have you installed any new apps recently (can be 1 day or a few weeks) prior to experiencing this behavior?
    – Aeronautix
    Commented May 31 at 5:05
  • It seems that a software conflict is interfering with the Spotlight GUI. The next step is to test in safe mode.
    – Linc D.
    Commented May 31 at 16:49
  • @Aeronautix. mdutil -sav returns /, Data, Preboot enabled. Did not install anything I can think of (but the computer is also remotely managed, so who knows what IITS is doing behind my back!). Yes I tried mdutil -Ea. Nothing good.
    – Maber
    Commented May 31 at 20:46

0

You must log in to answer this question.

Browse other questions tagged .