I've got a somewhat puzzling problem here (or at least, I find it puzzling).
I'm going to go into great detail in the hope that it helps someone to point me in the right direction, and also in the hope that a potential solution might help someone else in the future - so please forgive me if some of the info here might not turn out to be relevant to the problem!

TL;DR: When disconnecting the iPod from my Mac (after ejecting from iTunes) the iPod thinks there is no music on it.
If you get bored by the details, please scroll down to the bottom for a summary of what I've done to try and fix this.


I have an iPod Classic which I bought just under a year ago.

I use the iPod almost exclusively connected to the aux input of a car stereo (aboard a boat, actually), rather than with headphones.
I normally charge it via the USB mode of the same car stereo.

Every now and then, the iPod freezes. In particular, it very often freezes when plugging it into the stereo (USB mode) to charge, or when unplugging it. I simply reboot it (or reset, as Apple like to say) by holding down the play and menu buttons, and then all is well.

Recently (in the last couple of weeks) the iPod started to reset certain settings whenever it froze and had to be rebooted. After every reboot it would ask for the language to be set - something it never used to do - and it also sometimes reset other settings; such as enabling the clicking sound when scrolling.

The Problem

Yesterday, I plugged the iPod into my MacBook Pro (Late 2008, OS X Lion 10.7.2, iTunes 10.5.3), to transfer (I manage the iPod manually rather than with auto sync) some new music from my iTunes library.

When I finished, I ejected the iPod from within iTunes, as usual, and then unplugged the iPod when it told me it was ok to do so.
Rather than going straight to the music screen, as usual, the iPod rebooted (reset) itself. As I mentioned above, the iPod is sometimes a little strange about rebooting so I didn't think anything was strange. But...

When the iPod came on again, it had no music on it! Nothing. It appeared to be empty. Looking in the Settings->About screen, I could see that in fact the amount of space corresponding to my files was still being used - the hard drive hadn't been wiped, but rather the data, or the iPod's database, had presumably become corrupted in some way.

Fortunately I have all of my music on my Mac in my iTunes libraray, so this wasn't a total disaster. I thought I'd simply have to restore the iPod to factory settings and then put all my music back on. How naïve of me. I should know better.

When I plugged the iPod back into the computer, it didn't appear in iTunes. After some time, it appeared in the Finder, and iTunes froze. Ejecting the iPod took ages, and looking at it with Disk Utility caused Disk Utility to freeze. Odd.
I also tried opening exPod, just to see if it would work - but no; it also froze.
No combination of rebooting the iPod and computer, relaunching iTunes, etc, would make the iPod show up in iTunes.

Trying To Fix It

The first thing I tried was the iPod's built-in diagnostics, started by pressing menu+left whilst booting. But it couldn't find anything wrong.
I also tried starting the iPod in disk mode - it didn't help.

After everything else I could think of - including everything in Apple's awful support site, and failing to find anything relevant via Google - I eventually resorted to this technique (reformatting the iPod with Disk Utility), supposedly "The Super Fix for Most iPod Problems".
Actually I wasn't able to reformat the disk from Disk Utility, due to POSIX permissions errors, but I did eventually manage to format it from the Terminal using diskutil. And before you ask, I used the Extended Journaled format, with Apple Partition Map - as the iPod was previously.

And this fixed the not showing up in iTunes problem - I was able to restore the iPod from iTunes, and then add some music to it.

But guess what? Right. When I ejected it, it did exactly the same thing as before: the music all "disappeared", and the iPod wouldn't show up in iTunes.

More Attempts At Fixing It

Well, as you can guess, I was getting pretty fed up by now... But what could I do but keep on trying?

My next step was to format the hard drive as FAT32, from Disk Utility, and then initialise the iPod from iTunes as if it were a new iPod. This resulted in iTunes identifying the iPod as a Windows iPod, though in fact I had never connected it to Windows.

Now I tried adding content again, and this time, it actually worked! When I disconnected my iPod after adding one album to it, the album stayed on it!
Phew. Problem solved, I thought. Me being naïve again...

So, I proceeded to copy a few tens of gigabytes of music to the iPod, then I disconnected it - and we were back with the same old problem. F*ck. :'(

So, my final brainwave (well, maybe not...) was to actually format the iPod from Windows, via Parallels.
Unfortunately, I was unable to make iTunes on Windows download and install the firmware, but I did the next best thing. Just like above, I formatted the iPod as FAT32 from Disk Utility and then initialised the iPod from iTunes on OS X, resulting in an apparently "Windows-format" iPod, and then instead of adding music from my Mac, I connected it to Windows and added music from there.

So far (touch wood) I haven't had the problem when disconnecting from Windows.
So, I'm assuming this is a problem on my Mac (ie, in OS X) rather than on my iPod.
UPDATE: I have now had the same problem on Windows, so I guess this is an iPod problem.


So, to summarise the problem and the step sI've taken to solve it:

  • When disconnecting the iPod from my Mac (after ejecting from iTunes) the iPod thinks there is no music on it.
  • When connecting the iPod to the computer again after this, it doesn't usually show up in iTunes. Occasionally it does show up, and iTunes says it is corrupted and needs to be reset.
  • Formatting the iPod from Disk Utility and then restoring, or simply initialising, the iPod from iTunes doesn't solve the problem - it makes the iPod show up in iTunes again, but the problem occurs again as soon as I disconnect the iPod again.
  • It doesn't make any difference if I format the iPod as HFS+ Extended Journaled or as FAT32.
  • Managing the iPod from Windows, however, seems (tentatively; ie thus far) not to cause the problem.
    UPDATE: I have now reproduced the same problem via Windows.

So, what is the problem?

So, based on all the above, it looks like probably a problem in OS X. But I haven't been able to find out where the problem would be, or even for sure if it is an OS X problem.

I'd tentatively guess that it might be a problem with /System/Library/Extensions/iPodDriver.kext, but I don't know how I can check that (removing iPodDriver.kext stops the iPod from showing up in iTunes at all, and I don't know where I can get a "clean" iPodDriver.kext to replace it with).

UPDATE: I have now had the same problem on Windows, so I guess this is an iPod problem.

If anyone has any ideas, or can point me in the right direction, I'd be really grateful. I've reached the end of my troubleshooting abilities, and am at a lost end as to what else I can try.

Oh, and thanks for getting to the end of my monumentally long post! :-D

System Info

  • MacBook Pro, Late 2008
  • OS X Lion 10.7.2
  • iTunes 10.5.3 (yes, I know there is a newer version. I'm trying to download it, but havent had good enough internet yet)
  • Firmware 2.0.4 (latest version)
  • Model MC293
  • 3
    If anyone is looking for an example of how to ask a troubleshooting question, here is the canonical Way To Do It! Well asked.
    – Daniel
    Apr 2, 2012 at 15:54

7 Answers 7


I have an alternative take on this problem:

I have just bought a Classic 160 Gb at Amazon few weeks ago and I have been facing the same issues as you.

I do not use Mac OS X, nor iTunes to sync. I run Linux and I use Media Monkey on a Windows VirtualBox Machine.

During the past two weeks I have tried everything that I could find. iTunes have not even been able to read my entire collection (strange, right?)

My findings

I have just restored the iPod firmware a few minutes ago. Started MediaMonkey and sync'd 10 songs from an ordinary random artist. Disconnected and the songs were there, nice. So the iPod is actually working. So far, so good, I have figured that out before.

However, in the meantime, while I was checking my library, I recalled that I have some songs from Japanese bands with Japanese characters in their names. Historically, this would be very error prone. So I did gave it a try, and sync'd 64 songs from that band. Disconnected the iPod and the songs were all gone.

So apparently the 2.0.4 firmware does not handle these characters very well. Check your library, make smaller tests. I am about to restore the iPod again and will try to sync some more files with normal ASCII characters. Will update you.

My old, now dead (waiting for a new disk), iPod, running 1.0.2 was able to hold those files nicely.

  • SOLVED. Turns out that the problems were not with special characters. After my post, I made some additional tests, and suspected from some incompatibility between Media Monkey and the version of the iTunesDB, but I disregarded that in sequence. My last attempts would be to either try to sync using a native MacOS or Windows instead of a virtual environment...and...bang! it worked. I took another notebook running windows, installed all software, imported my library, sync'd the ipod and now I have my songs back on the car!! =)
    – william
    Dec 3, 2012 at 14:43

Given your problems, I think it's extremely unlikely that this is a problem with Mac OS X, even though you haven't yet reproduced the same error with Windows. While not beyond the realm of possibility, it seems extremely unlikely that a failure in Mac OS X would only affect one device, and in such a specific way.

You mention you bought this just under a year ago. If so then it's still under warranty. I suggest returning it to Apple and getting it replaced, it sounds like you've having serious problems with this device. Describe the problems you're having, or, if you can, demonstrate it to them, and they'll most likely replace it.

The only reason I can think why they would not is that you mentioned you use this device on a boat - if it got splashed, that would be considered "liquid damage" and is not covered by the warranty.

  • Thanks for the quick answer! The iPod certainly hasn't been wet; I've always kept it inside the boat. I guess it's a damper atmosphere than being on land, but I haven't had problems with other devices including computers which have been used aboard daily over a period of many years. I will try finding an Apple store and taking the iPod in - but the problem is that I'm abroad at the moment. I don't know what effect that has on the warranty. I won't be back home before the warranty expires...
    – Caesar
    Apr 2, 2012 at 15:48
  • @caesarsgrunt I'm pretty sure any store will do. If you bought directly from Apple you don't even need a receipt - they can just look up the date of purchase on their system. Apr 2, 2012 at 15:54
  • Unfortunately I bought it from Carrefour in France, but I do have the receipt (I think...). I'll try and find out about my nearest Apple retailer. Thanks for your help!
    – Caesar
    Apr 2, 2012 at 15:56
  • Just an update to say that you're right; I have now reproduced the same problem from Windows. According to Apple's website my warranty has expired "based on the estimated expiration date", but my receipt indicates that I purchased the iPod mid-May 2011. I guess I just have to show the receipt as proof in an Apple Authorized Service Provider.
    – Caesar
    Apr 2, 2012 at 17:11
  • @caesarsgrunt I think Apple's site bases the warranty off of when the iPhone was sold to the reseller, but I'd imagine they'd honor a replacement if you had a receipt. Good luck! Apr 2, 2012 at 17:59

For what it's worth; this eventually turned out to be a hard disk issue.

I had the hard disk replaced and it has performed fine since.

I must say, I am still surprised that a hard drive issue could have these particular symptoms. I, and various people I showed it to, thought it must be a logic board problem.


So i was having the same problem over and over again after using the Erase thing. So I read your whole thing in frustration and tried things til it worked for me. And my solution might be something you've essentially tried, but I might as well tell you cuz I had thought I'd done this too.

Put your iPod in DISK MODE and connect to disk utility, then erase it. Unplug it. Plug it back into iTunes, restore it. Eject it after it's all restored and updated. Plug it again and add something small.

The key for me was I had "Formatt[ed] the iPod from Disk Utility and then restor[ed], or simply initialize[ed]" like you did, but it wasn't in Disk Mode when i did it. So i added a whole library, and it I thought it had worked (the whole reason I had "erased" it was cuz it would freeze every time it synced) - but then I saw nada.

Hope this works for you!

Here are the instructions again so you don't miss anything.

  • Welcome to Ask Different! While the link you posted may answer the question, it is best to summarize the contents of the link in your answer, then provide the link for reference. Links have a tendency disappear over time, leaving a non-applicable answer for those who may stumble upon your answer in the future.
    – daviesgeek
    Jul 19, 2012 at 21:23

I've had similar problems to the OP with my iPod Classic 7th gen which I upgraded to a 128GB Kingspec SSD (beware, the 6th/7th gen Classic is a bitch to open!). On connecting to Windows it went into a 'restore' loop or iTunes just wouldn't recognise the iPod at all.

The way I got around this was to format first on a mac then did the restore on Windows (message 'this is a Mac-formatted iPod, please restore' or something similar). Restore and sync then went through fine and the machine worked perfectly

BUT a couple of days later, following an iTunes sync I then got exactly the same problem as the OP. The iPod turned on fine but although it showed the right memory allocated there was no content.

Recovery mode and restore didn't work (as before) so I went back to restore on the mac then on to PC where I was eventually successful after a couple of false starts.

So I'm wondering if this is something to do with compatibility with the SSD HDD. I also have an iPod Video 5.5th generation which I've fitted with a 128GB half-size SSD (super light, fast and very easy to fit). It restored and synced first time - I'll report back if I get any issues.

  • FWIW, my iPod did the same thing again a couple of weeks back. Haven't done anything about it yet, but I guess if I fix it the solution will be an SSD. Alternative is just to migrate to a cheap Android phone with a big microSD card, but the battery life will be crap...
    – Caesar
    Feb 23, 2016 at 3:01

i have purchased a new ipod classic 160gb as i thought my old one had a malfunction. My new one has the same problem i have also tried two different laptops so its obviously not an ipod problem or laptop problem


I have a 5yo ipod 160GB. It has >11,000 songs & 291 movies. It had your same problem when I didnt eject my ipod prior to disconnecting from itunes. I reconnected to itunes that night , ejected then it the songs, playlist & movies came back. I listened to music the next 2 days. I bought music from the itune store from my iphone then i tried to put them in the ipod via itunes who sync'ed the new album from icloud. While i was dragging the album to my ipod, it registered that it was disconnected then the ipod displayed Connected, eject before disconnecting. Upon soft reset, the ipod said no music nor movies. I tried to hook back to itunes, all songs & movies are there & can even play in the itunes. But it wont eject right and will just spontaneously disconnect, ipod hanged with the dont disconnect display , soft reset will just display no music everytime. Saw all your stories & tricks that didnt work. Our local mac expert recommended to restore the ipod. I did not coz it will remove all my hard work. I just reconnected the ipod to the itunes and patiently waited for the eject icon to appear. Mind you that it was a 3 minute wait like a dial-up internet. This time, it showed ipod updating even if the IOS is up to date. The ipod icon disappeared in the desktop but the ipod display is still eject prior to disconnecting. I did a soft reset again & this time, the apple icon on the ipod displayed longer than usual. And viola, the songs, playlist & movies are back in the ipod display! I dont know which worked. I just tried to be patient and hoped for the best. It worked! I would never connect the ipod to the itunes again!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .