0

Both of my two Macs have recently suffered from a problem where suddenly Spotlight will no longer open files or applications. For example if you search for the string setting it will show System Settings but if you press enter or click on the result, absolutely nothing happens—the menu just closes. It also does the same for apps that are already running, and for files that previously used to cause apps to open those files.

This is kind of maddening; I use Spotlight to switch between apps and open particular files all day every day. So I'm 100% sure that in both cases it was working totally fine, and then it suddenly just stopped, in the second case I'm pretty sure it stopped while I was using the computer.

In both cases this happened only after updating to Sonoma (currently 14.5 23F79). For my iMac it was soon after updating, maybe several days in. For the laptop it was a few weeks after updating. For the iMac I could never make it work again, even after reboots; I had to reimage the machine and afterward the problem was gone. The laptop just started having the problem today a few hours ago, and it went away after rebooting, but now it's back a few hours later. I guess I'll reimage it too, but I'm terrified the problem will come back in a few weeks.

Most other reports are about Spotlight not even showing apps in the first place. This is not that problem: the apps show up, but don't activate when I select them. I've tried rebuilding the Spotlight index with sudo mdutil -a -E, but it didn't help.

I know this is a very vague report, and I apologize. Does anyone have any idea what might be causing this?


Update: the problem seems to center around a conflict resolution dialog for an iCloud drive document that I open all the time with Spotlight. Currently if I killall -9 Spotlight Spotlight works totally fine exactly until I try to use it to open a markdown file called reply.md. When I do that nothing happens, and then no other apps can ever be activated again.

If I instead try to open that file with Finder, I get the "Modifications aren't in sync. Choose which versions to keep." dialog. Sometimes when I choose one to keep I get an error about how Finder couldn't open TextMate. Other times it works.

It seems like the Spotlight process is maybe hanging when it tries to open that document and needs to show the conflict resolution dialog (which worked fine before Sonoma). I don't know why Finder also can't open the file sometimes even after I respond to the dialog.

6
  • 1
    Please boot in safe mode and test. Same?
    – Linc D.
    Commented May 23 at 21:43
  • Not vague at all. Concise and to the point. From my research on the web there are Spotlight problems with Sonoma. You might try Settings > Siri & Spotlight and uncheck every category under Search results. Then close Settings, reopen, and check the categories you need. You might want to start with the first: Applications. Report back.
    – IconDaemon
    Commented May 24 at 0:09
  • Thanks. That didn't fix it, and the fun part is that when I reopen Settings they're all checked again even though I unchecked them. :-( I also tried Raycast, and it has exactly the same problem with not being able to activate apps a while after rebooting.
    – jacobsa
    Commented May 24 at 0:54
  • I did notice that killing the Spotlight process with killall -9 Spotlight at least temporarily fixes the problem. I can also fix Raycast by quitting and reopening it. This is still super annoying, but a better workaround than a reboot or reimage. :-/
    – jacobsa
    Commented May 24 at 0:58
  • (I also narrowed down the problem a little bit; see the update in the question.)
    – jacobsa
    Commented May 24 at 1:03

0

You must log in to answer this question.

Browse other questions tagged .