3

Pretty often if I start an app (which I primarily do from command-space, i.e. Spotlight) the system executes the program, but the window is buried, so I have to then search for it in the switcher. I rarely if ever want something started that way to be buried, what controls that?

This has been true for quite a few versions of macOS, it happened just now on 14.5.

9
  • Does the menu bar switch to the started app?
    – hym3242
    Commented May 15 at 22:11
  • Not sure, right now Console is behaving... as is everything else I've tried.
    – Hack Saw
    Commented May 15 at 22:21
  • oops, I edited that, I meant command-space, the search thing
    – Hack Saw
    Commented May 15 at 22:22
  • Yah launching from Sherlock should pop the app to the frontmost window. I'm wondering if you have a window management tool running or some such. If you reboot with SHIFT held down (for Intel Macs) or hold the power button for Apple Silicon and select safe mode and see if the behavior is different. Failing that create a new temporary user profile and try it there. That might show a setting got damaged in your primary account. Commented May 15 at 22:54
  • 1
    @SteveChambers Sherlock? Not these past 20 years! ;-)
    – benwiggy
    Commented May 16 at 11:13

1 Answer 1

1

Secure Keyboard Entry

A consistent way to cause applications to launch in the background is to enable Secure Keyboard Entry in the Terminal application.

  • Terminal.app > Terminal (menu) > Secure Keyboard Entry

Screenshot of macOS Terminal.app with a menu item highlighted

It's also in iTerm2, in: Iterm2.app > Iterm2 > Secure Keyboard Entry

When this feature is enabled, applications across the whole of macOS no longer launch in the foreground.

This feature should be a System Setting, as it affects all applications, but is oddly hidden within Terminal.

7
  • 1
    I experience the same problem as @HackSaw but am not using Secure Keyboard Entry. macOS has had annoying focus (and focus-stealing) bugs since Sonoma. See forums.macrumors.com/threads/…
    – luckman212
    Commented May 18 at 14:12
  • That's not at all what Terminal's help file says about that setting. From the page: "Secure keyboard entry can prevent other apps on your computer or the network from detecting and recording what you type in Terminal."
    – Hack Saw
    Commented May 19 at 19:04
  • @HackSaw absolutely. The setting's behaviour, at least on my systems, is consistent and does not match the documentation. This appears to be a bug either in macOS or in the documentation. Commented May 20 at 8:31
  • Well, in any case, it's not enabled on my system. I don't use Terminal anyway, preferring iTerm2.
    – Hack Saw
    Commented May 20 at 21:13
  • 1
    Thanks, Graham!
    – Hack Saw
    Commented May 20 at 21:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .