2

Is the USBC port supposed to charge normally? I have never made it work properly.

I have tried all kinds of different chargers and cable combinations. At best its plugged in and not charging or charging slower than discharging.

Oddly, even a USBC cable directly connected to the megsafe brick is not working.

I even bought a "high performance 120W" cable, that shows me the wattage and it always shows just a couple of watts at best.

4
  • 1
    If you think there's something wrong withe hardware, take it to an Apple Store. (I haven't tested USB charging on my M1 MBPs.)
    – benwiggy
    Commented May 9 at 20:27
  • Im not sure if its wrong or just what its like or if Im doing it wrong? Commented May 10 at 19:57
  • 1
    Is this new behavior or were you never able to charge by USB-C? It charges with MagSafe though, correct? Are the chargers and cables from Apple? Are there any markings on the charger or cable that indicate support for USB-PD? I've seen USB-C chargers and cables that will be rated for something like "high performance 120 watts" but do not support USB-PD and so will only charge Apple devices at 5 or 12 watts as specified by USB 1.1, 2.0, and BC. They will provide 120 watts, or whatever, but only to devices that use the same charging standards.
    – MacGuffin
    Commented May 11 at 4:00
  • @MacGuffin I even tried an apple USB C cable connected directly to megsafe brick. But I don't know anything about USB-PD. Commented May 19 at 16:53

1 Answer 1

1

All Apple Silicon-based Mac portable computers take a charge from USB C and supports the Power Delivery protocol for effective charging whether your adapter is rated from 20w to 200W in my experience.

Above is one M1 specification, you should look up your model and then get hardware repair advice if known good chargers and cables are not working to power the Mac. Bring your chargers and cables with you when you get service.

You also should go through all steps in the article below, in order and consider remote Apple support as that is often the most effective of your time if the problem is missing a step or procedural on your part.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .