5

I installed Windows 7 on my (month-old) Macbook Pro using boot camp assistant. I basically used defaults throughout, so I don't think there's anything crazy about my setup.

Usually, after doing this, I would be able to see the Windows 7 partition mounted by OS X, but this time it's missing. The option to use my Boot Camp install is grayed out in Parallels, I assume because it doesn't see the Windows 7 volume (since it's missing.)

I am able to boot into both Windows 7 and OS X and use both of them fine. Windows 7 sees the OS X partition.

I can't seem to find any information about this problem, except some whisperings on some forum, which seemed to suggest that my GPT partition map was out of sync with my MBR partition map. Unfortunately, I can't find that forum post again. This might be a red herring!

I tried doing a Disk Repair in OS X disk utility, but it just tells me it couldn't repair it, and that I should backup everything and reformat (it says that something is broken.) Is there a better way? I am comfortable with commandline tools and doing insane things with partitions, especially if the alternative is to start all over again.

Here is the output of doing sudo fdisk /dev/disk0

         Starting       Ending
 #: id  cyl  hd sec -  cyl  hd sec [     start -       size]
------------------------------------------------------------------------
 1: EE 1023 254  63 - 1023 254  63 [         1 -     409639] <Unknown ID>
 2: AF 1023 254  63 - 1023 254  63 [    409640 -  708837376] HFS+        
*3: 07 1023 254  63 - 1023 254  63 [ 709249024 -     204800] HPFS/QNX/AUX
 4: 07 1023 254  63 - 1023 254  63 [ 709453824 -  267317248] HPFS/QNX/AUX

Man, I'm sorry I totally haven't had time to look into this and respond to the many people trying to help me. I will probably have some time over the coming holidays.

8
  • Did you install the NTFS-3G driver?
    – Am1rr3zA
    Commented Dec 8, 2010 at 16:44
  • I did not. I don't think I should need to for read access, though. Commented Dec 8, 2010 at 16:50
  • OSX cannot read NTFS natively. NTFS-3G is for both read AND write access. Commented Dec 8, 2010 at 18:10
  • 3
    OS X has had NTFS support from 10.3, according to wikipedia. On my other Mac, this worked as I described, and I didn't have to install NTFS-3G. Either it is installed when you setup boot camp or parallels, or it is not needed. Commented Dec 8, 2010 at 18:29
  • 2
    @VxJanoxV: Snow Leopard can read NTFS natively. Files on my NTFS Bootcamp partition even appear in Spotlight searches. Commented Dec 8, 2010 at 20:38

1 Answer 1

1

Try the fdisk option that repairs the MBR? -u I think.

1
  • There is no fdisk in Windows 7.
    – kinokijuf
    Commented Dec 1, 2011 at 8:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .