I am currently having issues connecting with my Mac (Sonoma 14.4.1) to certain webpages using the wifi of my institution, and I am completely clueless about why this is happening, because from my understanding this problem is limited to Macs connecting to the wifi.

The problem is that some websites (arstechnica.com and news.ycombinator.com are a couple, but I found more) do not load, and I cannot upload images on Notion (and sometimes Slack, but that's slightly more reliable).

Things I checked:

  • The web pages are not down.
  • The issue is limited to Macs connected to the wifi. I tested Android phones, iPhones, laptops running both Linux and Windows, as well as a few more Macs. None of the Macs were able to connect to the pages when connected to the internal wifi.
  • The web pages are not blacklisted, because otherwise I wouldn't have been able to connect using the other devices.
  • It's a wifi problem, because I was able to connect to the web pages using an ethernet cable.
  • The DNS is the same for all the devices I tested. ETA: I have tried to set the DNS manually, as well as test with Google's DNS (, but neither worked.
  • ETA: I set Ipv6 to link-local and rebooted. That did not fix the problem.

I understand that I should be asking the IT support for my institution, but so far we haven't been able to find a solution.

I'm not even sure what could be the cause or where to look for a solution, so any advice or direction would be welcomed. Thanks!

  • 1
    Have you tried disabling IPv6 on the Mac to see if the institution has a broken IPv6 setup?
    – jksoegaard
    Commented Apr 24 at 11:21
  • I tried to set it to "link-local only" and rebooting, but it did not fix the issue.
    – RCap107
    Commented Apr 24 at 11:49

2 Answers 2


Even if you stated that the DNS is identical for all devices, it's possible that Macs might still encounter DNS-related problems. To troubleshoot, you can try manually configuring the DNS servers on your Mac and see if that helps resolve the issue.

  • I manually set both the DNS provided by my institution (which was used by default to begin with), as well as Google's DNS to see if it helped, but the problem wasn't solved.
    – RCap107
    Commented Apr 24 at 12:17

After some more debugging with IT support, what seems to have fixed the issue was the good old "turn it off and back on again".

For whatever reason, it seems like the access point closest to my office was misbehaving. After rebooting it, the issue disappeared.

So, if you experience something similar, try to move to a different part of the building to see if it's an issue with the access point you're connected to, and then talk with IT support to try and reboot the bad APs.

Now, I still have no clue why this problem affected only Macs while other devices worked properly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .