I installed the OpenZFS on Mac v2.2.2 package for Big Sur 11.7.9, gave it access through the Security Preferences, and rebooted.

I used diskutil to erase an external SSD drive I'm testing with. When I erased the volume, I put Mac OS Extended on it.

I then created a single volume pool on the device.

zpool create -f mypool  /dev/disk6s2

I used -f because without it, it complained about the FS already there.

Everything seemed to go fine.

# zpool status mypool
  pool: mypool
 state: ONLINE

    mypool      ONLINE       0     0     0
      disk6s2   ONLINE       0     0     0

errors: No known data errors

I then tried to copy a 20GB file on my internal drive I had handy using the Finder.

It started copying fine, but then, everything came to a screeching halt.

Most notably, my mouse was unresponsive. I'd move it and it would crawl across the screen. I noticed on the Activity Monitor that both the Read and Write speeds were getting slower and slower, from 100+MB/s down to below 20. After some very careful and patient mouse positioning, I managed to cancel the copy. CPU load was not particularly notable.

The machine went back to its normal responsiveness.

This machine is a 2020 Intel iMac with 72GB of RAM.

A while (year or so) ago I tried ZFS. That time, I created two partitions and tried to mirror them. But, again, performance was terrible. I thought it was because I mirrored to halves of the same physical drive (not a practical solution, but I was just playing around). But this time, it was the whole volume.

If it matters, I'm running a Logitech MX Master 3 keyboard and mouse.

Curious if anyone else has seen anything like this. ZFS is essentially unusable for me because of this.

  • Are you comfortable opening some shells and having an iostat and top going and repeating a much much smaller copy? You’ve got enough resources on that Mac to diagnose a performance problem if you start with smaller copies. I would also recreate your pool and make a filesystem with these settings before testing.
    – bmike
    Commented Apr 18 at 21:34


You must log in to answer this question.

Browse other questions tagged .