0

The keyboard shortcut Cmd++ for zooming in did not work in Affinity Photo, so I tried to set this shortcut manually in the app's shortcut editor. This was not successful unfortunately (Affinity first showed Cmd+!, then Shift+Cmd+1 in the menu), but what is worse: it also changed the zoom-in shortcut in the Apple Preview app to Cmd+!. It seems that Affinity changed a global setting. Reverting the Affinity shortcuts to "Serif defaults" or "Apple defaults" did not restore the correct shortcut in the Preview app.

I have MacOS Ventura with a Swiss German keyboard layout. As a workaround, I added the German (Standard) keyboard layout. When this layout is activated, the shortcut in the Preview app changes back to Cmd++. But I would like to permanently restore the original behaviour.

Is there a way to find out what settings were changed by Affinity, and to revert them?

The Affinity forum mentions several issues with keyboard shortcuts, but it is unclear whether they have been fixed already.

1 Answer 1

0

I was mistaken: the shortcut Cmd+! was not caused by my changes in Affinity Photo. Instead, this seems to be a property of the Swiss German keyboard layout. Whenever it is activated, the zoom-in shortcut changes to Cmd+!.

I solved the issue by defining an app keyboard shortcut Cmd++for the Preview app in the system settings (using the + key on the numeric keypad – otherwise the shortcut would have been registered as Cmd+Shift+1, as + is above 1 in the Swiss German layout).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .