1

I have a Macbook Pro, with Sonoma, and a set up with 3 monitors:

  • Left: laptop monitor as Extended display
  • Middle: central monitor as Main monitor
  • Right: right monitor as Extended display

All displays have more than one desktop, and on the left (laptop monitor) I have a desktop with the messaging apps, email, calendar... and some others.

Problem: Sometimes after locking the screen and unlocking it, the desktops from the left and right displays are switched over, and I have all the desktops of the left monitor on the right one, and all the desktops of the right one on the left one.

I haven't found a workaround to switch the desktops. If I want to I have to move window by window from a desktop to the other. And it is driving me a bit nuts.

Is there any way to configure or deal with this switch of displays?

0

1 Answer 1

0

This appears to be a long standing issue, with many users complaining.

From this post on Desktop arrangement lost after waking from sleep

I had a long call with Apple Support yesterday. They recommended un-checking the "Automatically rearrange Spaces based on most recent use" (Number 1 below) and checking the "Displays have separate Spaces" (Number 2 below) under the Mission Control in the System Preferences.

Below is a screenshot of what I've done by following their advise.

enter image description here

There is another potential solution that involves creating a new user, from this post, but it sounds a bit dubious to me:

Looks like I have a fix, after 1h call with support and some experimenting.

Step 1: create different local user and check if problem occurs again. For me, it didn't.

Option with new user is nor really good for me, as it means another onboarding process with my corporate, means new device ID, certificates, blahblah.

Step 2: shut down Mac, ten tap and hold power button for Startup options, choose options -> disk utility, and check Macintosh HD for errors -> "health check". For me, it didn't find anything.

Step 3: (being logged into your user) Finder -> Go-> Library -> LaunchAgents, delete everything inside, not the folder itself.

Step 4: go to Macintosh HD -> Library -> LaunchDaemons, delete everything inside, not the folder itself.

Restart Mac.

Now sleeping and waking, unplugging and plugging back - all app windows are back where I left off. Finally.

There is another option, which seems more of a workaround, rather than a fix, of making your laptop monitor the main screen, (which may be a sub-optimal solution for you). From this post

I may have found a solution. It's as simple as setting your built-in screen as the Main display instead of the external screen. It might not resolve the issue 100% but at least I haven't had to rearrange my windows every time the screen goes to sleep mode.

enter image description here

That thread has a number of other suggestions and potential solutions (there are 121 answers, at the time of writing).

1
  • 1
    Thank you. It is definitely this same problem. My settings config are as stated in the first option... So probably not a fix for me. The second one, yep, it is a company laptop and setting up a new user is not an option. The third one maybe I'll try it. Thank you very much!
    – Pedro R.
    Commented Apr 2 at 14:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .