1

I want to get rid of some system services completely. I turned off sip with csrutil disable. Then following command

sudo launchctl disable com.apple.cloudphotod

Gave me an unexpected answer:

Unrecognized target specifier, did you mean
gui/501/com.apple.cloudphotod

I've read man, searched forums and so on. But I can't get why do I need specify the context agent is running in, how do I know that from launchctl list and is the a way to avoid the need to specify it? There are many services and I'm completely uncertain which one is in which context.

Side question: I also was looking for a gui tool such as Windows Services.msc, found Soma-zone's LaunchControl. Downloaded tar.gz archive, unarchived, started the app, and... it says "can't open the app". Did I miss something and tar.gz needs some special handling? Never dealt with that.

4
  • RE: your "side question": It's been a while since I first installed LaunchControl, but IIRC: dbl-click on the tar.xz file decompresses it, leaving you with an.app file. Move that to your Applications folder. After that, if it won't start, you'll need to go into your Systems Settings app & figure out what to click to convince the "Apple Security Guardians" that you give permissions for it to run. There are probably better instructions at somazone.com - or email for tech support... Robby will answer & he's a great resource.
    – Seamus
    Mar 30 at 0:02
  • Sadly there hasn't been anything like this in settings app. But it lead me to think there are some rights problems with executable bin. And there was - tried chmod, got another error. Finally tried using archive tool instead of winzip - voila! It worked! Mar 30 at 0:43
  • 1
    winzip - On a Mac??. No wonder you had problems. :) Anyway - glad to see you've resolved it. I think you'll like LaunchControl.
    – Seamus
    Mar 30 at 1:08
  • Why do you want to unload it? If you're not using iCloud Photos, it's not going to use any CPU, even if loaded. I must have about 800 processes all using 0% CPU right now.
    – benwiggy
    Apr 29 at 12:36

1 Answer 1

1

Caveat: most of this is completely unoriginal on my part.

Here is a script which can stop and disable lots of macOS services. Disable Sonoma Bloatware by Bogdan. I know of this because Bogdan/b0gdanw is a regular and trusted MacRumors contributor. This list is for macOS Sonoma. Services may be different for older macOS.

You will see that it correctly specifies the domain for each service. This is the gui/501/ that you got as a suggestion. System daemons have system as domain.

So for your specific services the correct commands are:

launchctl bootout gui/501/com.apple.cloudphotod
launchctl disable gui/501/com.apple.cloudphotod

This assumes that your UID is 501 which is standard for the first admin user created at macOS installation.

Don't be tempted just to run the script! Heed the WARNING! The script is meant to show how and what can be disabled. Don’t use it as it is, adapt it to your needs.

As to why specify the domain: There may be more than one user on your Mac and each (if logged in at the same time) will have services running. And there are system services in their own domain system.

For a gui interface, I use two apps which do much the same thing:

1
  • Many thanks, I'll invistigate it deeper. I upvoted your answer but I don't have enough reputation to vote yet, so it doesn't appear( Apr 2 at 16:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .