I have an Apple M1 macbook pro in which I want to use SBCL for Common Lisp but without homebrew. The official SBCL page says one way is to build SBCL from source, though you need to bootstrap that with an existing common lisp compiler.

In order to bootstrap, I tried downloading the macOS AMD64 precompiled binary 2.2.9 for SBCL on the official SBCL page, and it's an older version (not as new as the source code of course). However, I couldn't run it because macOS said it's from an untrusted developer Of course, you can right-click the icon and click open, but then you'd need an admin password to be able to bypass the requirement of signing.

Of course, another thing I can do is to just install Brew outside of the usual prefix (so that sudo is not needed), then brew install SBCL (which would basically give me the newest version), and then if I wanted to, I could just use that to build SBCL from source, then finally delete the brew SBCL and brew itself.

However I'm wondering if there's any way to bootstrap without brew at all? Like is there a lightweight common lisp compiler that can be used to build SBCL on macOS apple silicon (even using Rosetta), that does not run into "untrusted publisher" issues (so that I don't need sudo or admin password to run it)?

EDIT: I tried to download the ARM64 version 2.4.0 instead, and managed to run install.sh fine. But then when I cded to bin and did ./sbcl, I get a popup saying

"sbcl" can't be opened because Apple cannot check it for malicious software. This software needs to be upaded. Contact the developer for more information.

Also I forgot to add that I'm on a standard account on the macbook, not an administrator account. I do have access to the administrator account, but I would prefer not to use it: I install and use lots of other software no problem on my standard account.

  • sbcl.org/platform-table.html offers 2.4.0 as an ARM version (and 2.2.9 for AMD64), both run on my M1 Mac without problems (or complaints about being from an untrusted developer). How did you run the binary you downloaded, what exactly was the error message you got?
    – nohillside
    Commented Mar 24 at 16:05
  • 1
    @nohillside in my original question I had used the AMD64 version since I didn't see the ARM column. I tried that but still got the same result. I edited the question and added the popup messages I've been getting.
    – xdavidliu
    Commented Mar 24 at 20:11
  • 1
    – nohillside
    Commented Mar 24 at 20:19

1 Answer 1


as mentioned in the comments of the question, I did xattr -d com.apple.quarantine ./sbcl and it was able to run sbcl (the 2.4.0 arm version binary). Did not need admin password or anything for this to work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .