0

I'm trying Alacritty on MBP M2 connected to a Lenovo 4K monitor. I wanted to enable True Colors support as indicated as one of the salient features of the software.

My minimal YAML configuration and setting TERM to alacritty as advised in this Unix.SE post Why would I set TERM to xterm-256color when using Alacritty?. In fact I tried this answer, which didn't work.

[shell]
program = "/opt/homebrew/bin/fish"

[font]
size = 15
normal = { family = "Fira Code", style = "Regular" }
bold = { family = "Fira Code", style = "Bold" }
italic = { family = "Menlo", style = "Italic" }

[window]
startup_mode = "Maximized"
dynamic_title = true

[env]
TERM = "alacritty"

[scrolling]
history = 100000

[terminal]
osc52 = "CopyPaste"

[selection]
save_to_clipboard = true

I verified that True colors is still not supported by trying out this method as below, from here and here

enter image description here

At this point, contradicting to what is indicated here termstandard/colors, it says doing the print below should be in brown color. On my Alacritty terminal it prints

enter image description here

So my question, is my Alacritty configured to support true colors or not?

0

You must log in to answer this question.

Browse other questions tagged .