0

I use Raycast instead of Spotlight, so I've re-assigned the cmd-space hotkey to Raycast and disabled the shortcut in System Settings > Keyboard > Keyboard Shortcuts > Spotlight.

Until recently this worked fine, but lately the shortcut keeps getting re-enabled and I have to go into System Settings and disable it after every reboot.

  1. What would cause this? Searching the internet it seems like this isn't a common problem.
  2. As a workaround can I write some time of a script that will run at startup to disable it?
2
  • Instead on disabling try reassigning to another key combination. Commented Mar 18 at 17:17
  • I have tried that, for some reason it also doesn't work.
    – user448830
    Commented Mar 18 at 20:09

1 Answer 1

1

I tried the steps from https://old.reddit.com/r/MacOS/comments/194xe60/spotlight_keyboard_shortcuts_reset_after_every/kjzwhif/ and tentatively I think it worked!

If it was caused by a corrupt ~/Library/Preferences/com.apple.symbolichotkeys.plist file then deleting or renaming it before disabling the shortcut should allow it to "stick".

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .