1

I have an iPad and also a desktop computer, creatively named "John iMac 2017". When I open up Safari on the iPad, the homepage has a section "From John iMac 2017" which includes a link there from a webpage that I visited almost a year ago, but it is no longer open on the iMac. If I press and hold on that link, a menu comes up; the only apparently relevant item is "Close", and if I choose that, the link disappears from the homepage but then reappears about 5-10 seconds later.

How do I remove this link? Is there a cache that I can clear or something along those lines?

2
  • 1
    This is probably an iCloud sync issue and is probably solvable by signing out of iCloud on all your devices, then signing back in on each one. Mar 17 at 2:24
  • 1
    @LouieLouie: signing out and then back in on just the iPad seems to have resolved the problem. Thanks! Mar 17 at 15:52

2 Answers 2

3

Sign completely out of iCloud on your iPad, then sign back in. If that doesn't work, sign out of iCloud on all your devices that use iCloud, then sign back in.

This "switch it off and on again" approach can seem like a hassle, but it's often the only effective solution for iCloud-related issues and can avoid a lot of pain along the way.

1
  • Thanks, signing out and back in on just the iPad worked for me. Mar 17 at 18:13
0

It might be an error with handoff. Go to Settings-General-Airplay & Handoff And turn off handoff.

3
  • Turning off handoff made the link go away, but it reappeared when I turned it back on. Mar 17 at 4:13
  • I think that it is an error with handoff. Try removing your Mac from your Apple ID.
    – Plane_guy
    Mar 17 at 14:39
  • 1
    The "From <user's other device>" section of Safari's Start Page is an iCloud feature. If you click the settings icon in the lower right it's listed as "iCloud Tabs" and can be toggled on or off there. Mar 17 at 16:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .