2

I have MacBook Pro 2020, M1, 16GB RAM, MacOS Sonoma 14.3.1 (23D60).

For the last couple of months when I open my laptop in the morning, I find out that it got restarted. Over the last couple of weeks, this happens on a daily basis and sometimes even a multiple times a day - eg.

  • I open the laptop in the morning => it got restarted and loading everything from scratch
  • I close the laptop when I go for lunch, get back, open the laptop => it got restarted
  • I close the laptop when I go home, open it later in the evening => it got restarted

I purchased it in 2020, so there' no warranty anymore. I've got to the point where I am worried to keep any data on it because of the fear of losing it.

After the MacBooks loads up, there's the following window on the screen: enter image description here The full output of the message is below:

panic(cpu 2 caller 0xfffffe0031930a8c): "virtual IOReturn ADPParamFIFO::programFIFO(IOMemoryMap *): ADP FIFO still busy after 1000ms" @ADPParamFIFO.cpp:263
Debugger message: panic
Memory ID: 0x6
OS release type: User
OS version: 23D60
Kernel version: Darwin Kernel Version 23.3.0: Wed Dec 20 21:30:27 PST 2023; root:xnu-10002.81.5~7/RELEASE_ARM64_T8103
Fileset Kernelcache UUID: 55F9AB4B8DBAB485904EAE23F4B4F7A5
Kernel UUID: A515349E-37D8-3DBE-B33A-79A09D832553
Boot session UUID: 7FAE5403-1C5D-48DE-9492-4E3DB85F135C
iBoot version: iBoot-10151.81.1
secure boot?: YES
roots installed: 0
Paniclog version: 14
KernelCache slide: 0x0000000027e64000
KernelCache base:  0xfffffe002ee68000
Kernel slide:      0x0000000027e6c000
Kernel text base:  0xfffffe002ee70000
Kernel text exec slide: 0x0000000029378000
Kernel text exec base:  0xfffffe003037c000
mach_absolute_time: 0x28f5dd2827
Epoch Time:        sec       usec
  Boot    : 0x65e207e7 0x00057368
  Sleep   : 0x65e244c1 0x000d1c98
  Wake    : 0x65e247fe 0x0009947a
  Calendar: 0x65e24a40 0x000c5bd9

Zone info:
  Zone map: 0xfffffe101ed5c000 - 0xfffffe301ed5c000
  . VM    : 0xfffffe101ed5c000 - 0xfffffe14eba28000
  . RO    : 0xfffffe14eba28000 - 0xfffffe16853c0000
  . GEN0  : 0xfffffe16853c0000 - 0xfffffe1b5208c000
  . GEN1  : 0xfffffe1b5208c000 - 0xfffffe201ed58000
  . GEN2  : 0xfffffe201ed58000 - 0xfffffe24eba24000
  . GEN3  : 0xfffffe24eba24000 - 0xfffffe29b86f0000
  . DATA  : 0xfffffe29b86f0000 - 0xfffffe301ed5c000
  Metadata: 0xfffffe79f2978000 - 0xfffffe79fa978000
  Bitmaps : 0xfffffe79fa978000 - 0xfffffe79fd760000
  Extra   : 0 - 0

CORE 0 recently retired instr at 0xfffffe00305289bc
CORE 1 recently retired instr at 0xfffffe00305289bc
CORE 2 recently retired instr at 0xfffffe00305271c0
CORE 3 recently retired instr at 0xfffffe00305289bc
CORE 4 recently retired instr at 0xfffffe00305289bc
CORE 5 recently retired instr at 0xfffffe00305289bc
CORE 6 recently retired instr at 0xfffffe00305289bc
CORE 7 recently retired instr at 0xfffffe00305289b4
TPIDRx_ELy = {1: 0xfffffe1685888838  0: 0x0000000000000002  0ro: 0x0000000000000000 }
CORE 0 PVH locks held: None
CORE 1 PVH locks held: None
CORE 2 PVH locks held: None
CORE 3 PVH locks held: None
CORE 4 PVH locks held: None
CORE 5 PVH locks held: None
CORE 6 PVH locks held: None
CORE 7 PVH locks held: None
CORE 0: PC=0x000000019c2e7888, LR=0x000000019c1133c4, FP=0x000000016f1539e0
CORE 1: PC=0xfffffe0030a482cc, LR=0xfffffe0030a0c45c, FP=0xfffffe8e18243a50
CORE 2 is the one that panicked. Check the full backtrace for details.
CORE 3: PC=0xfffffe003040ff50, LR=0xfffffe003040ff50, FP=0xfffffe8e182f7ef0
CORE 4: PC=0xfffffe003040ff54, LR=0xfffffe003040ff50, FP=0xfffffe8e17ce7ef0
CORE 5: PC=0xfffffe003040ff54, LR=0xfffffe003040ff50, FP=0xfffffe8e1817fef0
CORE 6: PC=0xfffffe003040ff54, LR=0xfffffe003040ff50, FP=0xfffffe8e183abef0
CORE 7: PC=0xfffffe003040ff54, LR=0xfffffe003040ff50, FP=0xfffffe8e18267ef0
Compressor Info: 11% of compressed pages limit (OK) and 12% of segments limit (OK) with 0 swapfiles and OK swap space
Panicked task 0xfffffe24ebacabe8: 0 pages, 494 threads: pid 0: kernel_task
Panicked thread: 0xfffffe1685888838, backtrace: 0xfffffe8e17a2f640, tid: 354
          lr: 0xfffffe00303d5588  fp: 0xfffffe8e17a2f6d0
          lr: 0xfffffe003051fcfc  fp: 0xfffffe8e17a2f740
          lr: 0xfffffe003051e15c  fp: 0xfffffe8e17a2f830
          lr: 0xfffffe0030383b68  fp: 0xfffffe8e17a2f840
          lr: 0xfffffe00303d4e68  fp: 0xfffffe8e17a2fbf0
          lr: 0xfffffe0030be71f8  fp: 0xfffffe8e17a2fc10
          lr: 0xfffffe0031930a8c  fp: 0xfffffe8e17a2fc40
          lr: 0xfffffe003191ce74  fp: 0xfffffe8e17a2fc80
          lr: 0xfffffe00318e885c  fp: 0xfffffe8e17a2fcb0
          lr: 0xfffffe00318ecd00  fp: 0xfffffe8e17a2fd10
          lr: 0xfffffe00318fd974  fp: 0xfffffe8e17a2fdb0
          lr: 0xfffffe0032a704e0  fp: 0xfffffe8e17a2fdf0
          lr: 0xfffffe0032a62d50  fp: 0xfffffe8e17a2fe40
          lr: 0xfffffe0032a5e7ec  fp: 0xfffffe8e17a2fe70
          lr: 0xfffffe0030ae7c2c  fp: 0xfffffe8e17a2fec0
          lr: 0xfffffe0030ae3bd8  fp: 0xfffffe8e17a2fef0
          lr: 0xfffffe0030ae4788  fp: 0xfffffe8e17a2ff20
          lr: 0xfffffe003038ced8  fp: 0x0000000000000000
      Kernel Extensions in backtrace:
         com.apple.iokit.IOMobileGraphicsFamily(343.0)[D00527A6-C662-3549-AF22-CD7326E3B740]@0xfffffe0032a3d0e0->0xfffffe0032a7defb
            dependency: com.apple.driver.AppleARMPlatform(1.0.2)[603C49BE-3001-3033-B79E-584777C5610D]@0xfffffe0030d7fe30->0xfffffe0030dd296b
            dependency: com.apple.driver.AppleM2ScalerCSCDriver(265.0.0)[D89955BB-EE4D-3891-A3B1-AB4038DAFAA7]@0xfffffe00317b6060->0xfffffe0031847cc7
            dependency: com.apple.driver.AppleMobileFileIntegrity(1.0.5)[02D8CA71-FD1F-357B-BC14-D066241AAFA5]@0xfffffe0031930c30->0xfffffe0031960dff
            dependency: com.apple.iokit.IOAVFamily(1.0.0)[AFCB4C5E-420C-3D6D-AEF3-11775655299D]@0xfffffe003256cbc0->0xfffffe00325f671f
            dependency: com.apple.iokit.IOSurface(352.0.3)[0351AFC2-D85C-3BB5-B9C6-C8C0F6C7A01D]@0xfffffe0032c4ad80->0xfffffe0032c7b56b
         com.apple.driver.AppleMobileDispH13G-DFR(140.0)[B34A592B-A4CB-39A5-B4E4-D3B92C41F300]@0xfffffe00318e1000->0xfffffe0031930c23
            dependency: com.apple.driver.AppleARMPlatform(1.0.2)[603C49BE-3001-3033-B79E-584777C5610D]@0xfffffe0030d7fe30->0xfffffe0030dd296b
            dependency: com.apple.driver.AppleM2ScalerCSCDriver(265.0.0)[D89955BB-EE4D-3891-A3B1-AB4038DAFAA7]@0xfffffe00317b6060->0xfffffe0031847cc7
            dependency: com.apple.iokit.IOAVFamily(1.0.0)[AFCB4C5E-420C-3D6D-AEF3-11775655299D]@0xfffffe003256cbc0->0xfffffe00325f671f
            dependency: com.apple.iokit.IOMobileGraphicsFamily(343.0.0)[D00527A6-C662-3549-AF22-CD7326E3B740]@0xfffffe0032a3d0e0->0xfffffe0032a7defb
            dependency: com.apple.iokit.IOSurface(352.0.3)[0351AFC2-D85C-3BB5-B9C6-C8C0F6C7A01D]@0xfffffe0032c4ad80->0xfffffe0032c7b56b

last started kext at 2124063822: com.apple.driver.AppleUVDMDriver   1.0.0 (addr 0xfffffe002f46cd00, size 6519)
loaded kexts:
com.apple.filesystems.autofs    3.0
com.apple.driver.AppleTopCaseHIDEventDriver 7430.5
com.apple.driver.CoreKDL    1
com.apple.driver.AppleBiometricServices 1
com.apple.driver.DiskImages.ReadWriteDiskImage  493.0.0
com.apple.driver.DiskImages.UDIFDiskImage   493.0.0
com.apple.driver.DiskImages.RAMBackingStore 493.0.0
com.apple.driver.DiskImages.FileBackingStore    493.0.0
com.apple.driver.BCMWLANFirmware4378.Hashstore  1
com.apple.driver.SEPHibernation 1
com.apple.driver.AppleSmartBatteryManager   161.0.0
com.apple.driver.AppleThunderboltIP 4.0.3
com.apple.driver.AppleUSBDeviceNCM  5.0.0
com.apple.driver.AppleFileSystemDriver  3.0.1
com.apple.nke.l2tp  1.9
com.apple.filesystems.tmpfs 1
com.apple.filesystems.nfs   1
com.apple.filesystems.lifs  1
com.apple.filesystems.apfs  2235.80.4
com.apple.IOTextEncryptionFamily    1.0.0
com.apple.filesystems.hfs.kext  650.0.2
com.apple.security.BootPolicy   1
com.apple.BootCache 40
com.apple.AppleFSCompression.AppleFSCompressionTypeZlib 1.0.0
com.apple.AppleFSCompression.AppleFSCompressionTypeDataless 1.0.0d1
com.apple.driver.AppleALSColorSensor    1.0.0d1
com.apple.driver.AppleAOPVoiceTrigger   300.7
com.apple.driver.ApplePMP   1
com.apple.driver.AppleSmartIO2  1
com.apple.driver.ApplePMPFirmware   1
com.apple.driver.AppleTAS5770LAmp   700.46
com.apple.driver.AudioDMAController-T8103   300.15
com.apple.AppleEmbeddedSimpleSPINORFlasher  1
com.apple.driver.AppleDPDisplayTCON 1
com.apple.AGXG13G   276.62
com.apple.driver.AppleJPEGDriver    6.2.2
com.apple.driver.AppleSerialShim    1
com.apple.driver.AppleAVD   737.2
com.apple.driver.AppleAVE2  703.54.1
com.apple.driver.AppleMobileDispH13G-DCP    140.0
com.apple.driver.usb.AppleSynopsysUSB40XHCI 1
com.apple.driver.AppleCS42L83Audio  700.46
com.apple.driver.AppleSummitLCD 1.0.0
com.apple.driver.AppleEventLogHandler   1
com.apple.driver.AppleT8020SOCTuner 1
com.apple.driver.AppleT8103CLPCv3   1
com.apple.driver.AppleS5L8960XNCO   1
com.apple.driver.AppleT8103PMGR 1
com.apple.driver.AppleS8000AES  1
com.apple.driver.AppleS8000DWI  1.0.0d1
com.apple.driver.AppleInterruptController   1.0.0d1
com.apple.driver.AppleBluetoothModule   1
com.apple.driver.AppleSamsungSerial 1.0.0d1
com.apple.driver.AppleBCMWLANBusInterfacePCIe   1
com.apple.driver.AppleT8020DART 1
com.apple.driver.AppleSynopsysMIPIDSI   1.0.0
com.apple.driver.AppleS5L8920XPWM   1.0.0d1
com.apple.driver.AppleS5L8940XI2C   1.0.0d2
com.apple.driver.AppleSPIMC 1
com.apple.driver.AppleT8101 1
com.apple.driver.AppleM68Buttons    1.0.0d1
com.apple.iokit.IOUserEthernet  1.0.1
com.apple.driver.usb.AppleUSBUserHCI    1
com.apple.iokit.IOKitRegistryCompatibility  1
com.apple.iokit.EndpointSecurity    1
com.apple.driver.AppleDiskImages2   273
com.apple.AppleSystemPolicy 2.0.0
com.apple.nke.applicationfirewall   404
com.apple.kec.InvalidateHmac    1
com.apple.kec.AppleEncryptedArchive 1
com.apple.driver.AppleUVDMDriver    1.0.0
com.apple.driver.AppleUVDM  1.0.0
com.apple.driver.driverkit.serial   6.0.0
com.apple.iokit.IOAVBFamily 1220.1
com.apple.driver.AppleHIDKeyboard   7400.2
com.apple.driver.AppleActuatorDriver    7430.5
com.apple.driver.AppleMultitouchDriver  7430.5
com.apple.driver.AppleHSBluetoothDriver 7430.5
com.apple.driver.IOBluetoothHIDDriver   9.0.0
com.apple.driver.AppleMesaSEPDriver 100.99
com.apple.iokit.IOBiometricFamily   1
com.apple.driver.DiskImages.KernelBacked    493.0.0
com.apple.driver.AppleSEPHDCPManager    1.0.1
com.apple.driver.AppleTrustedAccessory  1
com.apple.iokit.AppleSEPGenericTransfer 1
com.apple.driver.AppleXsanScheme    3
com.apple.driver.AppleConvergedIPCOLYBTControl  1
com.apple.driver.AppleConvergedPCI  1
com.apple.driver.AppleBluetoothDebug    1
com.apple.driver.AppleBTM   1.0.1
com.apple.driver.AppleThunderboltPCIDownAdapter 4.1.1
com.apple.driver.AppleThunderboltUSBDownAdapter 1.0.4
com.apple.driver.AppleThunderboltDPInAdapter    8.5.1
com.apple.driver.AppleThunderboltDPAdapterFamily    8.5.1
com.apple.driver.usb.networking 5.0.0
com.apple.nke.ppp   1.9
com.apple.driver.AppleBSDKextStarter    3
com.apple.kext.triggers 1.0
com.apple.driver.IOHIDPowerSource   1
com.apple.driver.AppleCallbackPowerSource   1
com.apple.filesystems.hfs.encodings.kext    1
com.apple.driver.AppleSyntheticGameController   11.3.1
com.apple.driver.AppleDCPDPTXProxy  1.0.0
com.apple.driver.DCPDPFamilyProxy   1
com.apple.driver.AppleAOPAudio  300.14
com.apple.plugin.IOgPTPPlugin   1230.2
com.apple.driver.AppleHPM   3.4.4
com.apple.driver.AppleStockholmControl  1.0.0
com.apple.driver.DCPAVFamilyProxy   1
com.apple.iokit.IONVMeFamily    2.1.0
com.apple.driver.AppleT8103TypeCPhy 1
com.apple.driver.AppleDiagnosticDataAccessReadOnly  1.0.0
com.apple.driver.AppleNANDConfigAccess  1.0.0
com.apple.driver.AppleT8103PCIe 1
com.apple.AGXFirmwareKextG13GRTBuddy    276.62
com.apple.AGXFirmwareKextRTBuddy64  276.62
com.apple.driver.AppleSART  1
com.apple.iokit.IOGPUFamily 93.10.1
com.apple.driver.AppleH13CameraInterface    8.301.0
com.apple.driver.AppleSPMIPMU   1.0.1
com.apple.driver.AppleDialogPMU 1.0.1
com.apple.driver.AppleSPMI  1.0.1
com.apple.driver.AppleH11ANEInterface   7.300.0
com.apple.iokit.IOMobileGraphicsFamily-DCP  343.0.0
com.apple.driver.AppleUSBXDCIARM    1.0
com.apple.driver.AppleUSBXDCI   1.0
com.apple.iokit.IOUSBDeviceFamily   2.0.0
com.apple.driver.AppleHIDTransportSPI   7410.1
com.apple.driver.AppleHIDTransport  7410.1
com.apple.driver.AppleSPU   1
com.apple.driver.AppleInputDeviceSupport    7410.1
com.apple.driver.usb.AppleSynopsysUSBXHCI   1
com.apple.driver.usb.AppleUSBXHCI   1.2
com.apple.driver.AppleEmbeddedUSBHost   1
com.apple.driver.usb.AppleUSBHub    1.2
com.apple.driver.usb.AppleUSBHostCompositeDevice    1.2
com.apple.driver.AppleCSEmbeddedAudio   700.46
com.apple.driver.AppleEmbeddedAudio 700.46
com.apple.iokit.AppleARMIISAudio    300.11
com.apple.driver.AppleDCP   1
com.apple.driver.AppleFirmwareKit   1
com.apple.driver.ApplePassthroughPPM    3.0
com.apple.driver.ApplePMGR  1
com.apple.driver.AppleARMWatchdogTimer  1
com.apple.driver.AppleDisplayCrossbar   1.0.0
com.apple.iokit.IODisplayPortFamily 1.0.0
com.apple.driver.AppleTypeCPhy  1
com.apple.driver.AppleThunderboltNHI    7.2.81
com.apple.driver.AppleT8103PCIeC    1
com.apple.iokit.IOThunderboltFamily 9.3.3
com.apple.iokit.IOPortFamily    1.0
com.apple.driver.ApplePIODMA    1
com.apple.driver.AppleMultiFunctionManager  1
com.apple.driver.AppleBluetoothDebugService 1
com.apple.driver.AppleBCMWLANCore   1.0.0
com.apple.iokit.IO80211Family   1200.13.0
com.apple.driver.IOImageLoader  1.0.0
com.apple.driver.AppleOLYHAL    1
com.apple.driver.corecapture    1.0.4
com.apple.driver.AppleEmbeddedPCIE  1
com.apple.driver.AppleMobileDispH13G-DFR    140.0
com.apple.iokit.IOMobileGraphicsFamily  343.0.0
com.apple.driver.AppleM2ScalerCSCDriver 265.0.0
com.apple.driver.AppleMCA2-T8103    800.11
com.apple.driver.AppleEmbeddedAudioLibs 300.1
com.apple.driver.AppleFirmwareUpdateKext    1
com.apple.driver.AppleGPIOICController  1.0.2
com.apple.driver.AppleFireStormErrorHandler 1
com.apple.driver.AppleMobileApNonce 1
com.apple.driver.usb.AppleUSBHostPacketFilter   1.0
com.apple.iokit.IOTimeSyncFamily    1230.2
com.apple.driver.DiskImages 493.0.0
com.apple.iokit.IOGraphicsFamily    598
com.apple.iokit.IOBluetoothFamily   9.0.0
com.apple.driver.AppleSSE   1.0
com.apple.driver.AppleSEPKeyStore   2
com.apple.driver.AppleUSBTDM    556
com.apple.iokit.IOUSBMassStorageDriver  243
com.apple.iokit.IOPCIFamily 2.9
com.apple.iokit.IOSCSIBlockCommandsDevice   492
com.apple.iokit.IOSCSIArchitectureModelFamily   492
com.apple.driver.AppleRSMChannel    1
com.apple.iokit.IORSMFamily 1
com.apple.driver.AppleLockdownMode  1
com.apple.driver.AppleIPAppender    1.0
com.apple.driver.AppleFDEKeyStore   28.30
com.apple.driver.AppleEffaceableStorage 1.0
com.apple.driver.AppleCredentialManager 1.0
com.apple.driver.KernelRelayHost    1
com.apple.iokit.IOUSBHostFamily 1.2
com.apple.driver.AppleUSBHostMergeProperties    1.2
com.apple.driver.usb.AppleUSBCommon 1.0
com.apple.driver.AppleSMC   3.1.9
com.apple.driver.RTBuddy    1.0.0
com.apple.driver.AppleEmbeddedTempSensor    1.0.0
com.apple.driver.AppleARMPMU    1.0
com.apple.iokit.IOAccessoryManager  1.0.0
com.apple.driver.AppleOnboardSerial 1.0
com.apple.iokit.IOSkywalkFamily 1.0
com.apple.driver.mDNSOffloadUserClient  1.0.1b8
com.apple.iokit.IONetworkingFamily  3.4
com.apple.iokit.IOSerialFamily  11
com.apple.driver.AppleSEPManager    1.0.1
com.apple.driver.IODARTFamily   1
com.apple.driver.AppleA7IOP 1.0.2
com.apple.driver.IOSlaveProcessor   1
com.apple.driver.AppleBiometricSensor   2
com.apple.iokit.IOHIDFamily 2.0.0
com.apple.AUC   1.0
com.apple.iokit.IOSurface   352.0.3
com.apple.iokit.IOAVFamily  1.0.0
com.apple.iokit.IOHDCPFamily    1.0.0
com.apple.iokit.IOCECFamily 1
com.apple.iokit.IOAudio2Family  1.0
com.apple.driver.AppleIISController 300.1
com.apple.driver.AppleAudioClockLibs    300.1
com.apple.driver.FairPlayIOKit  71.3.0
com.apple.driver.AppleARMPlatform   1.0.2
com.apple.iokit.IOSlowAdaptiveClockingFamily    1.0.0
com.apple.iokit.IOReportFamily  47
com.apple.security.quarantine   4
com.apple.security.sandbox  300.0
com.apple.iokit.IOStorageFamily 2.1
com.apple.kext.AppleMatch   1.0.0d1
com.apple.driver.AppleMobileFileIntegrity   1.0.5
com.apple.iokit.CoreAnalyticsFamily 1
com.apple.security.AppleImage4  5.0.0
com.apple.kext.CoreTrust    1
com.apple.iokit.IOCryptoAcceleratorFamily   1.0.1
com.apple.kec.pthread   1
com.apple.kec.Libm  1
com.apple.kec.Compression   1.0
com.apple.kec.corecrypto    14.0



** Stackshot Succeeded ** Bytes Traced 679089 (Uncompressed 1767136) **

How do I fix this problem? Is it even fixable? I tried to google some solutions on the Apple's "official" forum, but unfortunately with no success.

Any advice would be highly appreciated.

EDIT #1: log show --style syslog | fgrep "panic" enter image description here

log show --style syslog | fgrep "panic"

enter image description here

System Power Settings

enter image description here

EDIT #2

log show --predicate 'eventMessage contains "Previous shutdown cause"' --last 24h

enter image description here

EDIT #3

Login Items

enter image description here

sudo log show --debug --signpost | grep -i Panic -> https://pastebin.pl/view/fb23c747

4
  • I have this problem too, exactly, on a Mac Book Pro, 13in, 2020, with Sonoma 14.2.1. I took my laptop to the Apple store, where they did the free diagnosis and found nothing. They invited me to leave the laptop with them for a for-pay repair, which I did not do yet (I needed to backup my data first). To my question if this is a known bug (it appeared after a system update) the answer was no.
    – costila
    Commented Mar 2 at 18:30
  • I think I got this from a question here, but try asking the log system in the terminal: log show --predicate 'eventMessage contains "Previous shutdown cause"' --last 24h. Mine is always 20 which turns out to the trusted computing module thingy.
    – JL Peyret
    Commented Mar 3 at 6:03
  • Thanks @JLPeyret - I added the output to the OP. Shows only zeros, though.
    – user984621
    Commented Mar 4 at 8:01

4 Answers 4

2

First, even though the warranty has expired, you can still take it to an Apple Store for a free diagnosis. They should be able to determine whether it's a hardware or software fault, at least. And you should always (in any case) back up your data regularly to another device, to avoid any data loss.

I don't see any reference to third-party software, but I would maybe check what you have installed, particularly under System Settings > General > Login Items > "Allow in the background".

You could also try a Safe Boot (boot while holding down SHIFT), and see if the problem occurs there, and then restart normally.

Try creating a new user account, and see if the problem occurs when you log into that. If not, then you know the problem relates to some software in use in your original account. If it still happens, then the problem is at the system level, which could still be software-related, or a hardware issue.

1
  • Thanks @benwiggy, I'll test it out. Re Apple Store and a free diagnosis, unfortunately there's no Apple store in my country.
    – user984621
    Commented Mar 4 at 7:50
1

That looks like the FIFO (First in First out) did not exit after given the Sign command in given time (no sleep possible, system restarts.

Just for fun, lets crosscheck you Sleep settings, here are mine

sleep

Following that lets look into what is happening by running following in Terminal to show the Panic logs.

log show --style syslog | fgrep "panic"

Then evaluate the problem with

sudo log show --debug --signpost | grep -i Panic

Please report your findings

2
  • thanks, I just added the two logs to the OP. Regarding the "System Power Settings" you posted to your answer, how do I obtain that?
    – user984621
    Commented Mar 4 at 7:47
  • Founded the "System Power Settings" and added the screenshot as well
    – user984621
    Commented Mar 4 at 7:56
0

Sorry had to start new answer, it was getting to busy.

First you have the message as for the reason for Panic.

panic(cpu 2 caller 0xfffffe0031930a8c): "virtual IOReturn ADPParamFIFO::programFIFO(IOMemoryMap *): ADP FIFO still busy after 1000ms" @ADPParamFIFO.cpp:263

Means it tried to shutdown an app but did not succeeded in the set time (1000ms) so it had to restart.

When it shutdown it uses the FIFO (first in first out) as order how to shut down.

The output of the log show --style syslog | fgrep "panic" shows the problem been in Login window.

For that open the System Preference >User&Groups>Login items and disable all automatic start ups.

It would be nice if you could get the

sudo log show --debug --signpost | grep -i Panic

to learn more

1
  • I attached the screenshot of Login Items to the OP. Do you want me to disable every single enabled item in the Allow in the Background list (such as DBXConverterUninstall.sh, Google LLC, ...)? Regarding the output of sudo log show --debug --signpost | grep -i Panic - I had to put it to a 3rd party link, the output is too lon to even screenshot it
    – user984621
    Commented Mar 6 at 7:52
-1

You can follow the instructions provided in this link, https://support.apple.com/en-hk/102550, to run a self-diagnostic test on your MacBook first. (This is one of the tests Apple's staff will run when you take your MacBook to the store.)

If it shows a failure, there isn't much you can do because it indicates a hardware failure.

If it reports OK, I strongly suggest you backup everything and reinstall the OS.

1
  • The OS is the one thing that is guaranteed to be OK. At best, reinstalling the OS will just empty some caches and temp files.
    – benwiggy
    Commented Mar 3 at 11:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .