3

Ever since upgrading to Sonoma I have not been able to access the Menu bar. I did change the shortcut long ago - and it had been working through various versions of macOS over the past decade.

Here is the current setting - CMD-;:

enter image description here

I have also tried various other keyboard combinations: none are working anymore. Any ideas why this is happening and if there are any workarounds?

Update I have tried a number of additional shortcuts. Nothing works. This used to work on Preview, Microsoft Word, PyCharm, Chrome .. none of them work.

Note also: This problem has persisted through every version of Sonoma that has been installed on this computer. It had worked in Ventura on this same computer.

Did Apple break this feature?

1
  • This may be solvable by finding and deleting the preference file that's responsible. You'll probably want a backup of the file so that you can re-add your other shortcuts in bulk. Much more detail in Preferences, permissions and problem-solving Commented Mar 28 at 23:40

2 Answers 2

3
+50

I found no definitive supporting documentation that this is indeed a bug but given that the problem didn’t exist in Ventura but manifested in Sonoma, it’s not unreasonable to believe that Apple broke something.

See this Mac Rumors forum post we they were apparently tweaking things on the Manu Bar early on.

The best thing to do is submit feedback to Apple: https://www.apple.com/feedback/macos.html

3
  • Thanks, i'll wait to see if anyone has anything more specific before awarding Commented Mar 29 at 1:49
  • I won't be submitting feedback: have done that in the past and never anything comes of it. I am extremely frustrated by this since macOS was already a gigantic drop in keyboarding support vs linux/windows. Commented May 20 at 15:46
  • Hi I found the problems and a workaround and so have set the correct answer to mine below. The 50 points and the upvote are still yours. Commented May 20 at 18:58
0

It appears that the problems are:

  • Moving focus to the menubar no longer unhides the menubar. I had Autohide set to true and it was working fine in earlier versions of the O/S
  • Clicking the keystroke combination no longer highlights the Apple icon. It highlights nothing actually.

The solution is:

  • Set MenuBar Autohide to Never
  • Hit the Menubar-focus key combination and then the first letter of the menu item . Only then will the menu be accessible [via up/down arrow keys or by hitting Enter]. The result of typing CMD-'-v is shown in this screenshot [ I use CMD-' for the "Set focus to MenuBar"]:

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .