3

Note: This is not a duplicate of “How to stop WiFi "Looking for Networks…",” the OP has a WiFi service running. I have totally disabled WiFi in my network preferences (see screenshot below) and the WiFi toggle is set to off in the menu. There should be no WiFi at all, but it still searches.


I am on an iMac using macOS Monterey (12.7.3).

Well the icon in the menu bar looks like it's searching for a network:

wifi icon 1 wifi icon 2 wifi menu

But it shouldn’t be when my network location is configured without a wifi service! it has only started to do this recently (that I’ve noticed).

enter image description here

3
  • 1
    I reopened your question, but the issue now is you don’t even show a Wi-Fi adapter you shouldn’t have the icon in the menu bar and if you are seeing the animation for scanning, that must be a bug. This is because if the hardware is disabled there’s no way they can search for networks, there seems to be something missing here might want to contact Apple support
    – Allan
    Feb 28 at 16:42
  • 1
    what do you use the ....lulu.app for
    – Ruskes
    Feb 28 at 21:17
  • 1
    Lulu is an outbound firewall and won’t be relevant for this situation. The answer is to not select WiFi from the menu at all, @Ruskes objective-see.org/products/lulu.html
    – bmike
    Feb 29 at 1:54

2 Answers 2

1

Take the WiFi icon out of your menu bar if you have disabled that network.

The coding is that the UI asks another process to do the scan and you’re likely seeing that default behavior not handle your test case. There’s no point in having that to even select if you know there is no WiFi.

3
  • I wouldn't be able to tell if it was searching without the icon
    – yarns
    Feb 29 at 19:46
  • How do you know it's searching and not just spinning a fake animation @yarns ?
    – bmike
    Feb 29 at 22:45
  • i thought that.. any ideas how to test? the console and system logs are overloaded without knowing what to search. i'll try wifi for starters but i cant reproduce the bug now anyway :S
    – yarns
    Mar 4 at 12:48
1

There are a few points to keeping the wifi icon in the menu bar even if wifi is disabled:

  • The icon provides quick access to the Network Settings window and is useful to have if you access it regularly.
  • When changing locations and network service configurations, it saves having to switch the Show Wi-Fi status in menu bar on and off.

To prevent WiFi from scanning for networks even when you don't want to use a WiFi service, add the WiFi service and set it to inactive. This produced the wifi icon greyed out with an ! which is how it was previously.

The scanning stopped and I still have quick access to my network settings.

Not sure why the behaviour changed with the wifi service removed and I haven't tested it again without a Wi-Fi service but making it inactive solved the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .