1

We just got fibre optic (I'm in the UK, using hyperoptic) so have a new WiFi router/network. Every other device except my MacBook Pro has successfully connected to the WiFi. It still connects to the old WiFi network and my mobile hotspot though.

When I try to connect, it buffers quite a while and then just stops and it says "connection failed" in the corner. In a few instances, after retrying over and over, it has said "the network could not be found" too.

I've tried running wireless diagnostics but it's not been helpful. It isn't actually giving me the option to try to fix anything but just tips and information? The three prompts it's giving me is: "Review Wi-Fi Best Practices" which is just a bunch of stuff I already know/tried; "Wi-Fi Not Associated" and this just tells me how to connect to a network, and "Poor Wireless Environment" but I've already tried connecting right next to the router and it's the same problem.

I've also tried a bunch of stuff I found online like resetting the NVRAM/PRAM and renewing the DHCP lease? I also changed my mobile hotspot from 2.4 Ghz to 5 Ghz to see if maybe the laptop was having trouble with that but it still connected fine.

Has anyone had any issues like this? Any tips on what to do?

1
  • I answered a similar question. The question was about network latency not connectivity, but the answer is the same: don’t use the ISP supplied router for WiFi. Instead, get a quality router/access point and use that. It’s also much more secure.
    – Allan
    Feb 25 at 20:49

1 Answer 1

1

If your network has just been recently set up, there's a chance it's using WPA3 security. Many routers will allow you to change the security, and, as far as I am aware, WPA2 is still relatively acceptable. You may even have a setting like WPA2/WPA3 that will let devices with WPA3 support use that and otherwise fall back on WPA2. According to Apple, only late 2013 Macs and onwards support WPA3, so I think your best bet is to change the settings in your router to enable WPA2, if that is the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .