0

had a crash a couple of years ago which resulted in a recovery from Backblaze (at the time).

Just discovered I didn't fully recover. Still have 3 zips, I only need parts of.

This is an example from zipinfo:

"-rw---- 4.5 fat 32952031 bX defN 22-Jun-30 19:23 OWC MiniStack/Music/Tom Waits/Mule Variations/03. Waits Tom - Hold on.m4a"

They're all CD rips. How would I unzip specific subfolders of the whole zip?

IE: /Tom Waits/

The whole zip is:

fritzs-mac-pro_2022.4.2_8-15-20-30-13 - T

2

1 Answer 1

0

The -C appears to be what you need:

unzip -C "fritzs-mac-pro_2022.4.2_8-15-20-30-13 - T" "OWC MiniStack/Music/Tom Waits/Mule Variations/*" -d ~/Downloads

From macOS's man zip entry:

-C

use case-insensitive matching for the selection of archive entries from the command-line list of extract selection patterns. unzip's philosophy is "you get what you ask for" (this is also responsible for the -L/-U change; see the relevant options below). Because some file systems are fully case- sensitive (notably those under the Unix operating system) and because both ZIP archives and unzip itself are portable across platforms, unzip's default behavior is to match both wildcard and literal filenames case-sensitively. That is, specifying "makefile" on the command line will only match "makefile" in the archive, not "Makefile" or "MAKEFILE" (and similarly for wildcard specifications). Since this does not correspond to the behavior of many other operating/file systems (for example, OS/2 HPFS, which preserves mixed case but is not sensitive to it), the -C option may be used to force all filename matches to be case-insensitive. In the example above, all three files would then match "makefile" (or "make*", or similar). The -C option affects file specs in both the normal file list and the excluded-file list (xlist).

Please note that the -C option does neither affect the search for the zipfile(s) nor the matching of archive entries to existing files on the extraction path. On a case-sensitive file system, unzip will never try to overwrite a file "FOO" when extracting an entry "foo"!

3
  • I used: unzip fritzs-mac-pro_2022.4.2_8-15-20-30-13 - T.zip "OWC MiniStack/Music/Thievery Corporation/*" -d The worked fine, but the new folder ended up on my start-up. I wanted the new folder to go to another disc and directory. In any case, I got them all done, just had to move the results by hand. I had tried adding: -d cd /Volumes/This/Folder But that wasn't it.
    – Fritz
    Feb 19 at 21:24
  • 1
    If you navigate to the drive where you want to place the files in finder, you can drop a folder into the terminal and macOS will escape the full path properly. Drag and drop for the win @Fritz (test with cd then drop and press enter to see this work safely)
    – bmike
    Feb 20 at 13:16
  • I'll try that. thanks
    – Fritz
    Feb 25 at 1:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .