7

I forgot my Apple MacBook Pro M2 password yesterday (running on MacOS Sonama) and after multiple tries, I tried to recover using recovery options provided by apple. After following all the steps loging in using my Apple ID.

In the reset password process, after I logged in using my Apple ID, it suddenly shows error “There was an error communicating with iCloud”. It happens right after the step where it tries to load FileVault recovery key.

I do have my FileVault recovery key and have all other passwords.

After contacting with Apple support and have a long conversation and they re-tried all the steps, they simply said: “well, you can only remove everything in your mac, we can’t help you more”

I even tried doing it using the terminal, and I can see a bunch of error printing in the terminal. Here I attached screenshot:

Screenshot of the terminal in the recovery page Screenshot of the iCloud error in the recovery page

Error above clearly indicates:

NSSoftLinking - The Shortcut framework’s library couldn’t be loaded from (null). The function ‘SCTInitShortcut’ can’t be found in the Shortcut framework. AOSKit: ERROR: CFBundleCreate failed (AppleAccount) ERROR: Failed to load AppleAccount

and continues: Missing ep for BTMM

Any idea? It seems I can’t try more passwords as when I try to enter new passwords it says “Account is locked”.

I can’t simply lose my data, it’s my PhD work/codes, and I don’t have backup. Can I do anything with the FileVault recovery key that I have? I don’t mind reinstall everything, but even reinstalling asks for password, which now seems locked.

3
  • 2
    Time for a backup! Nice work on documenting this for everyone…
    – bmike
    Feb 10 at 19:45
  • 1
    @bmike yeah, on my way buying a SSD for setting up time machine... Feb 10 at 20:38
  • 1
    For that encrypted drive, try a 4 dice words passphrase and write it in a sealed envelope for a bank vault and another send to a trusted friend.
    – bmike
    Feb 10 at 20:59

2 Answers 2

11

It seems like the issue was with my iCloud's "Advanced Data Protection" being turned on. It's a buggy feature, which will hopefully be fixed in future versions, but it seems it's not reliable today.

Thanks to my second attempt contacting Apple support, they suggested to turn it off and it worked.

In my iPhone (can be done in any other Apple device registered with the same Apple ID):

  1. I go to Apple ID setting (Settings > Select my name on top)
  2. Select "iCloud"
  3. Select "Advanced Data Protection"
  4. Select "Turn Off Advanced Data Protection"

Then, I tried the resetpassword command again in recovery mode, and this time it worked perfectly fine without showing any errors! Phew...

2

The most important thing is to get your files safe.

I would focus on borrowing a Mac that you know is working and then connect this Mac to the working one and see if you can recover the data to a hard drive and /or the Mac you’re borrowing.

This simplifies things greatly as you likely have a software corruption on the OS or account side and don’t even need to fix that once you have a backup.

It may take a week of effort to put Humpty Dumpty together again, so skip that pain by using your recovery key to mount the storage, copy off your work and then erase your Mac and move forward.

If you can’t get the data, I would pay a professional service and let them get your files. They have done this hundreds to thousands of times. You’ll have to learn all these skills and pay for software for one time use. Let them provide the software at a discount to you and get your files back.


Here is the process you and likely the recovery specialist will use:

They also have options to take apart the Mac and get a transfer even if the Mac won’t boot, but let’s start with the most likely options and go from there. Apple is correct, they don’t do data recovery services, but other companies do.

7
  • Thanks for the answer. I think my disk is locked at the moment. I also do not have a thunderbolt cable. On my way to buy one. Will update you soon. Feb 10 at 15:50
  • Based on all the attempts, it’s unlikely you’ll waltz right in, but I so hope that’s the case. You may need to mount the drive in disk utility or from the command line, but it will be good to confirm your options. If there’s a Genius Bar nearby, they also might be a great resource once you just need to boot to share disk mode and unlock with a key you have.
    – bmike
    Feb 10 at 15:57
  • Okay. I bought a Thunderbolt 4 cable. I tried instructions in the first link: it still requires me to unlock the disk to move files. I tried the second option, same. For the third one, even though the instructions are valid, but in recovery mode it seems like the disk is in read-only, so running diskutil corestorage list returnes empty. For the last link, I just set up a personal recovery key. I think I understood what's the problem, I'll explain in the next comment. Feb 10 at 17:46
  • The problem is that it seems my computer tries to load recovery key from my icloud account. But in reality, I didn't set the recovery key in the icloud. Instead, I set it up manually and I just don't understand why it tries to load FileVault recovery key from the icloud. I tried the same procedure with my wife's laptop and I could see the next step must be asking to enter FileVault recovery key, but in my case, it tries to load it from icloud, where there is no recovery key stored there. If I find a way to let BTMM asks for recovery key from a prompt instead of loading from icloud,it will work Feb 10 at 17:48
  • 1
    Nice work. So glad you confirmed data protection was the key here…
    – bmike
    Feb 10 at 19:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .