1

Since I switched from my MBP i9 (intel) to MBP M2 Pro (Apple silicon), I could no longer use Android File Transfer app to transfer files from any Android phone to my computer.

It always shows the message Could not connect to device.

I've tried to restart both, change cables, porta, even with another Android phone. On the new macbook, it simply doesn't work.

Everytime I need to transfer files, I need to use the old MBP. It works with the same phone, cable, etc, with no additional effort. enter image description here

I tried with an Android Pixel 2XL (running Android 11) and a newer Samsung Galaxy.

4
  • Are both Macs running the same macOS (e.g. "System Settings > Privacy & Security > Allow accessories to connect" might play a role?)?
    – Redarm
    Jan 28 at 10:24
  • If you used Migration Assistant to migrate the application, can you try the following: remove the application, reboot and then install it again from the website.
    – nohillside
    Jan 28 at 13:03
  • Is Preview.app open? If yes quit it (not just close it). Jan 29 at 20:16
  • Thanks for the comments. Both macs are on the same version. I didn't use Migration Assistant on the new mac. I've installed everything from scratch. I've tried closing Preview (and also relaunching Finder). Jan 30 at 4:56

2 Answers 2

0

It is likely because the link you supplied is for Intel only. It shows that it is for macOS 10.7 (Lion) which is ages before Apple Silicon existed.

While Rosetta normally handles running Intel code on Silicon, I have found that low level utilities like file transfer tools don’t play well. You’ll need to get an updated version of this app that is compatible with Apple Silicon.

2
  • It works for me, with an M1 mini and the version from the website (which seems to be from October 2018).
    – nohillside
    Jan 28 at 13:18
  • @Allan, it seems there is no updated version for Android File Transfer. Some people are able to use it, but not me. :( Jan 30 at 4:57
0

Worked for me on a M1 Mini with the application freshly installed from the website. Might help to click on "GET MORE HELP" at the bottom to see the steps required on the Android phone to enable transfers:

  1. Download and install Android File Transfer on your computer.
  2. Open Android File Transfer. The next time that you connect your device, it opens automatically.
  3. Unlock your device.
  4. With a USB cable, connect your device to your computer.
  5. On your device, tap the "Charging this device via USB" notification.
  6. Under "Use USB for," select File Transfer.
  7. An Android File Transfer window will open on your computer. Use it to drag files.
  8. When you’re done, unplug the USB cable.
2
  • This is the basic help, written everywhere. But didn't work for me. I only get the above dialog error when switching to File Transfer. Jan 30 at 5:08
  • @RicardoMartins uhh, ok. Might be worth mentioning this in the question.
    – nohillside
    Jan 30 at 5:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .