0

How to add/keep vscode in dock?

Here it says:

Add VS Code to your Dock by right-clicking on the icon, located in the Dock, to bring up the context menu and choosing Options, Keep in Dock

However it is just not working for me, this is what I'm getting when I'm right-clicking on the icon:

enter image description here

0

2 Answers 2

1

You can just drag the app itself into the Dock, anywhere left of the dividing line…
I don't have VS Code, but you can do this with any app.

enter image description here

You can remove an app by dragging it out from the Dock to the Desktop.

4

It appears that the icon you are referring to is a document icon and not the application icon.

If you want to keep the application icon in the dock then right click on the application icon (which should be on the left side of the dock), and use the contextual menu as you note in your post.

If you want to keep the document icon in the dock first locate the document in the Finder and drag it to the dock.

4
  • Well, the thing is, there is no application icon in the dock other than what I showed. I.e., there is no application icon on the left side of the dock, which is why I'm asking how to add it. In other words, if I don't start vscode, then there will be no vscode application icon on the dock at all.
    – xpt
    Jan 27 at 4:23
  • @xpt Just so I understand, you launch VS Code and the application icon for VS Code does not appear in the dock? Curious. Does VS Code have a setting to run as a menu bar app only?
    – SteveM
    Jan 27 at 18:02
  • I click and start the VS Code from the application. I've now used Tetsujin method to get one onto the dock myself.
    – xpt
    Jan 28 at 2:10
  • @xpt I'm glad you found a solution. But you did not answer my question. When you launch the VS Code application, did the VS Code application icon show up in the dock? This is the typical macOS behavior. And once an application is running, and its icon is in the dock, you can invoke the contextual menu, and choose the option to keep it in the dock.
    – SteveM
    Jan 28 at 2:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .