2

If I open Finder on my Mac, under settings I have it set to open at my home directory. From there I see Downloads, Music, Movies, Pictures etc directories. I don't see Documents though.

If I command + shift + . to see hidden files and folders, I still do not see Documents.

In the terminal if I type ls -l ~ I see the directories listed above AND Documents.

Whats happening here? How can I navigate finder using the directory structure?

enter image description here enter image description here

[edit] Adding output of ls -le@Od ~/Documents per comment enter image description here

12
  • 2
    Can you show output of ls -le@Od ~/Documents? If it has the hidden flag, do chflags nohidden ~/Documents.
    – Gilby
    Jan 20 at 10:20
  • 1
    Also, please copy/paste Terminal output as text and format as code. This makes it much easier to read for everybody and is essential for vision-impaired users.
    – nohillside
    Jan 20 at 12:57
  • 1
    Looks like Documents is in iCloud, or used to be in the past and resetting it back to local went wrong. Is there a Documents folder in iCloud, with your current content?
    – nohillside
    Jan 20 at 12:59
  • 2
    Please post your findings/solution as an answer, others may run into similar issues in the future and benefit from your analysis.
    – nohillside
    Jan 20 at 13:28
  • 1
    @DougFir As you wrote, it was just a comment with tools/info for you to solve your issue. Go on and post the answer - you know best.
    – Redarm
    Jan 20 at 13:37

1 Answer 1

3

The issue was that I was syncing Documents with icloud. After removing this sync ~/Documents appeared for me again in finder. Info in link in the comments.

What happens when you turn off iCloud Drive or sign out of iCloud?

If you turn off iCloud Drive or sign out of iCloud, a new Desktop and Documents folder will be created in your home folder. You also have the option to keep a local copy of your files that are in iCloud Drive. If you keep a local copy of your files that are in iCloud Drive, they will be copied to a folder called iCloud Drive (Archive) in your home folder. You can move any files that were in your iCloud Desktop and Documents to your new local Desktop and Documents.

2
  • Just to clarify: did you also (firstly) try and specifically only turn off Desktop & Documents in iCloud and it didn't recreate the local folders (i.e. the paragraph before the quoted one)?
    – Redarm
    Jan 20 at 13:48
  • 1
    @Redarm no, I switched icloud off entirely. I'm unsure of the outcome of the above. In my case I don't need it
    – Doug Fir
    Jan 20 at 13:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .