0

I'm running Ventura 13.6.1 on an Apple M1 Pro, and I'm having this issue with Ableton Live.

Somehow, all microphones just stopped working inside Ableton. Internal and external microphones, even though the permissions were set correctly to allow access to Microphone.

I've tried tccutil reset Microphone com.ableton.live, which successfully reset the permissions, but Ableton never asked for the permission again, so I have no way to give it Microphone permission.

I've also tried tccutil reset Microphone and reset all Microphone permissions, but Ableton is still not asking for permission. Every other app is actually asking.

Funny enough, when I open Ableton via terminal or iTerm, it requests permissions and I can actually record audio, but it's very annoying to have to open it via iTerm instead of double clicking on the project file.

I've searched all over the internet but everyone is talking about toggling the permissions, which didn't work for me when Ableton was listed in the Privacy settings, but now it's not even there.

I've also tried running tccplus as described in this answer, but there's no way I can get it to run thanks to the amazing work Gatekeeper does preventing me to run the software I want in my own laptop.

Any help is appreciated.

Thanks!

2
  • Is SIP on or off? For some reason if it's off, it can't ask.
    – Tetsujin
    Commented Jan 19 at 11:12
  • not sure what's SIP, but both iTerm and Terminal request the permission when I open Ableton through them. Commented Jan 19 at 17:53

1 Answer 1

0

Well, I think until they release an update which fixes this issue you basically solved the problem. Opening it via Terminal is the only solution and you saved my life.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .