2

I use Microsoft Remote Desktop to connect to 8 (yes eight) different computers each on its own virtual desktop, some MS Windows, some Linux, some Raspberry Pi OS (also Linux). There was always an issue with Microsoft Remote Desktop dropping the connections (to all machines) when the Mac turned its display off after a (settable) while. Up until (and including) Sonoma 14.0.0 there was a workaround by locking the screen using ctrl-cmd-Q instead of letting the Mac turn off the screen by itself. This kept the connections alive and they were still there when unlocking the screen again. After upgrading to 14.2.1 this no longer works. It is more than annoying having to re-establish 8 connections after each break.

Has anybody found a fix or at least a better workaround that still works with Sonoma 14.2.1?

2
  • system preference > battery> power adapter -- set display turn off to newer
    – Ruskes
    Commented Jan 17 at 2:44
  • 1
    Thanks @Ruskes - I've already tried that and you'r right, it prevents that disconnect from happening. However, it is neither an ecologically nor economically very desirable workaround - I have two big monitors attached to my Mac. I am afraid that neither Apple nor Microsoft are overly motivated to address the root cause of this problem that, as I said, has been around for a long time.
    – user147058
    Commented Jan 17 at 17:57

1 Answer 1

0

You want your Mac to keep the network connection for the Microsoft Remote Desktop while the display os off.

There are few ways to do that to keep the network connection alive.

For example Enable "Preventing your Mac from automatically sleeping when the display is off."

keep alive

3
  • That's it, @Ruskes!! "Preventing your Mac from automatically sleeping when the display is off." exactly establishes expected behavior, i.e. network connections are still up when I come back from a break during which the screen may have gone to screen saver and then off. Excellent! Thank you so much!!
    – user147058
    Commented Jan 19 at 0:12
  • @user147058 correct way to thank here is a upvote or acceptance of the answer
    – Ruskes
    Commented Jan 19 at 0:20
  • Upvoting requires "15 reputation" which I didn't know was a countable quantity and I certainly don't have, and accepting your answer is what I was trying to do but the "help" only says that I have the option to accept an answer but doesn't tell me how. So I resorted to the old-fashioned "thank you" - which is more appropriate for my age and hair color anyway :-)
    – user147058
    Commented Jan 19 at 0:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .